WordPress.org

Ready to get started?Download WordPress

Forums

Too many High memory usage notification Mails (6 posts)

  1. vsidharth
    Member
    Posted 2 years ago #

    Hi There,

    I am getting too many 'High memory usage notification' emails for my WordPress Website. With the below details:
    WordPress memory usage exceeded 64 MB
    WordPress peak memory usage: 68.08 MB
    Number of database queries: 97

    This started initially with a memory error on the webpage where my dashboard would not load.

    If you visit my Site, you will know it's not too huge, and has hardly any user base yet.
    http://www.testdp.webatu.com/www.dreamerzpassion.com/wordpress/

    Following are the various Steps I tried from the Instructions I found from various posts:

    1) Created a new php.ini file in wp-admin including a line memory_limit = 256M
    (I couldn't find a php.ini on my server) - when I contacted the service provided I have been told it is shared service and they can not amend that for me.

    2) Changed the default-constants.php file in wp-includes to set the memory limit to 128M,256M.

    3) Added the below line to the .htaccess file
    php_value memory_limit 128M

    4) Added the below line to wp-config.php File ini_set("memory_limit","128M");

    I am able to access my website but spammed with the 'High memory usage notification' emails in my inbox.

    Please help me fix this on a permanent basis. I am unable to spend more on and expensive hosting due to my financial condition.

  2. Vanguard Digital
    Member
    Posted 2 years ago #

    Hi there

    What sort of caching is your site using ?
    Have you installed WP Total Cache ? or similar ?

    In your hosting account admin you should be able to find out what files are causing the large amount of server load.

    Or contact your hosting support to find out what is causing the spikes as it will most likely be just one poorly written function that is causing the overage

    Hope this helps a little

    Cheers
    Nick

  3. vsidharth
    Member
    Posted 2 years ago #

    Hi,

    Thank you for your response, I am not aware of what kind of caching my site uses - how do I find that.

    And nope, I have not installed anything of that sort for caching by myself. Also I am not very techie to find out about what files are causing the large amount of server load.

    I am not having support from my hosting provider since I m using a the cheapest of the plans and unless I upgrade they are not going to provide me any support of that sort.

    Now, I have been able to stop the emails by deactivating the alerting feature on the 'TPC! Memory Usage' plugin but still unable to reduce the high memory usage, I have verified to see if I could deactivate any plugins but I need all of them.

    Thank you for your support.

    Merry Christmas!..

    Sid

  4. Start with turning off plugins, and switch themes. Twenty Eleven is pretty mild on the CPU.

    The caching tools listed are plugins (yes, we know saying 'use a plugin' and 'get rid of plugins' sounds inconsistant).

  5. vsidharth
    Member
    Posted 2 years ago #

    I am using Buddypress for Social website, so I am unable to use the twenty eleven since it is not compatible with Buddypress and I am not familiar with how to edit the code to make it compatible, though I tried using a plugin to make it compatible, it did not work..

    Also, the no. of plugins active on my website is 23. Is that too high a number. I like the amount of customization I got to make using these plugins and I would love to keep them for the benefits.

  6. jinkaid
    Member
    Posted 2 years ago #

    It may be the plugin: TPC! Memory Usage

    If you are using this plugin you can change the notification settings.

    Go to the Menu > Memory Usage
    Click on Settings
    Go down to the bottom of the page and change "Notify if memory usage exceeds:"

    That should fix your problem.

Topic Closed

This topic has been closed to new replies.

About this Topic