WordPress.org

Ready to get started?Download WordPress

Forums

NextScripts: Social Networks Auto-Poster
[resolved] Too many connections (7 posts)

  1. DominicanoBro
    Member
    Posted 1 year ago #

    Whenever i try to post to twitter i get this message

    Warning: mysql_connect() [function.mysql-connect]: Too many connections in /home/_shared/inc/functions.php on line 24
    Can't connect to the database. Too many connections

    any ideas why?

    http://wordpress.org/extend/plugins/social-networks-auto-poster-facebook-twitter-g/

  2. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    Are you always getting this (like with each twitter post or just with some)? Do you have Free or "Pro" version? Any other things/networks are not working?

  3. DominicanoBro
    Member
    Posted 1 year ago #

    Just with twitter, I am using a Free version.

    I first posted a twitter update yesterday and the link was working fine but today when I clicked on the link it would direct me to a blank page with the message above "Warning: mysql_connect() [function.mysql-connect]: Too many connections in /home/_shared/inc/functions.php on line 24"

    what i did was I switched the url shortener from the default to the wordpress built in shortener and it seems to be working fine with current twitter updates.

    I will keep updating as i go.

    Thanks,

  4. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    So this error happens when it autoposts on Twitter or when you click the link in the Twitter post that already autoposted?

  5. DominicanoBro
    Member
    Posted 1 year ago #

    When I clicked on the link in the Twitter post already autoposted.

  6. CouponCodePlugin
    Member
    Posted 1 year ago #

    That is your database saying that it has too many connections and can not process the connection required for you to view the webpage. It's like the server is saying "Im too busy, come back later". One or more of your plugins or large volumes of users are causing the database to be overloaded.
    Have you cached the site with something like w3 total cache plugin?
    Check with your host to ensure the database settings are good and can not be tweaked any further.

  7. DominicanoBro
    Member
    Posted 1 year ago #

    This issue has been resolved. I believe it had something to do with the url shortener service provided by the plugin.

    Thank you all,

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic