WordPress.org

Ready to get started?Download WordPress

Forums

Gravity Forms + Stripe
"token more than once" error suddenly appearing (4 posts)

  1. imagiNed
    Member
    Posted 1 year ago #

    I have a client site running WP 3.5.1 accepting payments on several different forms (implemented GF v1.6.11 + Stripe v1.6.11.1).

    Everything has been working properly until a few days ago, when suddenly, the system started failing with the following symptoms:

    After the "Submit Payment" button is clicked, the cursor spins for a while, then returns the error message: You cannot use a stripe token more than once.

    However, the payment is actually received into the Stripe account.

    Does anyone have any advice/insight in how to resolve this issue?

    http://wordpress.org/extend/plugins/gravity-forms-stripe/

  2. Luke McDonald
    Member
    Posted 1 year ago #

    I've been getting the same error recently. In some cases, users are able to submit the form successfully on the first try. In other cases, customers will submit the credit card info a couple times until the error eventually doesn't show the form and appears to process without an error. As @imagiNed mentioned, the payment is submission is processed and payment is successfully received by Stripe even though the error continues to show.

    Plugins Activated:

    • Gravity Forms: 1.6.12
    • Gravity Forms + Stripe: 1.6.11.1
  3. imagiNed
    Member
    Posted 1 year ago #

    Note to Luke McDonald:
    my client and I tried various solutions, contacting Stripe tech support and hiring Naomi to help us with troubleshooting. When she put the Stripe AddOn into test mode, the problem went away, even when she returned it to Live Mode. But then it resurfaced a few days later (with a somewhat different symptom: instead of the error message, a continuously spinning cursor - but the money still went into the account).

    What seemed the fix the problem for us (or at least, it hasn't resurfaced for 10 days now) was that we went to our Stripe account dashboard and updated the API from Nov 7th version to the Feb 13th version.)

    Naomi said it shouldn't have made a difference, but (apparently) it "jiggled" something and it did.

  4. redwall
    Member
    Posted 1 year ago #

    Hey Guys,

    I am now getting the same error when using subscriptions in test mode.

    I get an error in form once submitting (using test card numbers from Stripe site)

    Funny thing (same as above) The payment goes through to my Stripe dashboard regardless of the error, but the gravity from notifications do not get sent. So the user will think they have not paid and I won't know about it as the admin.

    Trying to get some help!

    Plugins:

    Gravity Forms + Stripe - 1.7.2.3
    Gravity Forms + (More) Stripe - 1.6.12.1.beta2
    Gravity Forms - 1.7.3

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags