WordPress.org

Ready to get started?Download WordPress

Forums

Table of Contents Plus
[resolved] TOC adding " (16 posts)

  1. vsalx
    Member
    Posted 1 year ago #

    Hi,

    there wasn't any problem at the beginning but for some time now when I try to use [toc] shortcode it adds "<" before the heading and before the table itself.

    Example:
    http://rattie.info/wp-content/uploads/2012/11/example.png

    P.S.: I'm with custom theme.

    http://wordpress.org/extend/plugins/table-of-contents-plus/

  2. Mike
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for raising that. It looks like an issue with handling the character set. Does it happen on all of your pages or just that one?

  3. vsalx
    Member
    Posted 1 year ago #

    On all pages. And to be more precise when it happened for the first time it was just on that page, but when I updated a page that previously used TOC+ and had no problem, after the update of the text on that page, it happened on it too. So every new page or updated one has the problem. :)

  4. Mike
    Member
    Plugin Author

    Posted 1 year ago #

    Are you able to link me to a page with the problem? I'd like to grab a copy of the content and see if I can get it doing how you describe.

  5. Mike
    Member
    Plugin Author

    Posted 1 year ago #

    Does it only happen when you use the shortcode or does it also happen when you let it automatically add it?

  6. vsalx
    Member
    Posted 1 year ago #

    It also happens with the automatically option turned on.
    Here's a page with the shortcode -> http://rattie.info/otglezhdane/dom-za-vashiya-plah/

  7. Mike
    Member
    Plugin Author

    Posted 1 year ago #

    I've copied your content but it doesn't produce the extra < for me which leads me to think that it could be another plugin interfering? I've tried editing the page many times but they all work. I added the following plugins you were using to see but they worked ok for me.

    Custom Contact Forms
    SEO Facebook Comments
    SimpleModal Login
    WordPress SEO
    WP Socializer

    Can you trace back when it started to happen, if you had just added some new plugins to your site?

  8. vsalx
    Member
    Posted 1 year ago #

    I think this is the post where it first happened -> http://rattie.info/okraski-pri-plahovete/ and toc+ was added on 24 of October as I see the revisions. And here is a post wich is not affected for now -> http://rattie.info/otglezhdane/hranene/ and is last updated on 21st October.
    I don't remember adding new plugins at that time but I could try disabling them one by one and see if any of them is the cause.

  9. Mike
    Member
    Plugin Author

    Posted 1 year ago #

    I've just pushed through a change to making the regular expression matching process a bit better as reported in

    At the same time, I've enabled UTF8 in the regular expression which should should be good for international characters.

    Do you mind giving the dev version a try to see if it helped fix your issue? After installing, you might need to edit the affected page and click update again.

    http://downloads.wordpress.org/plugin/table-of-contents-plus.zip

    If that didn't work, try making it run earlier by editing line 132 of toc.php and change 100 to 1. Additionally, try making it run later by changing the number to 1000.

  10. vsalx
    Member
    Posted 1 year ago #

    Now it seems fine but only with the auto insert option on and the value on line 132 equal to 1. With the shortcode it doesn't appear at all, and with values 100 and 1000 too.

  11. Mike
    Member
    Plugin Author

    Posted 1 year ago #

    Ok that means that other plugins are coming in and doing their stuff which is probably adding those extra < signs. Unfortunately, you've got two options:

    1. Disable plugins one by one to find out which plugin is doing it (then let me know so I can see if I can make it compatible with it).
    2. Edit that line with all new releases of TOC+

    Obviously option 1 is preferred but that will take some of your time which you may not have.

    By the way, shortcodes come in at level 10 so tell TOC+ to run 11 or onwards.

  12. vsalx
    Member
    Posted 1 year ago #

    Sorry, for my late reply.
    So I checked the plugins and it seems deactivating "WP Socializer" plugin activates the shortcode for TOC+.

  13. Mike
    Member
    Plugin Author

    Posted 1 year ago #

    WP Socializer doesn't produce the < for me so I can't confirm what you're getting. WP Socializer does have alot of PHP notices though.

  14. vsalx
    Member
    Posted 1 year ago #

    Yeah, I meant that now after the update it's fine without adding the extra "<" but using the shortcode doesn't produce the table at all unless I turn off WP Socializer.

  15. Mike
    Member
    Plugin Author

    Posted 1 year ago #

    Ok I think...!

    If you meant the update from http://wordpress.org/support/topic/toc-adding?replies=14#post-3376129 and you've still left it running at 1, try changing it to 11 as shortcodes run at 10.

  16. vsalx
    Member
    Posted 1 year ago #

    Sorry for the late late reply, everytihing seems okay now. Thanks for the support. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.