WordPress.org

Ready to get started?Download WordPress

Forums

Responsive Lightbox by dFactory
Titles not showing (8 posts)

  1. Zaphi
    Member
    Posted 2 months ago #

    Hi!

    I add titles and alt-texts to my galleries and the single images I publish but I does not work on my site or blog. I have set:

    Title show: Enable
    Title position: outside

    Please have a look at: http://www.viktorsundberg.se/galleri/modell-och-portratt/

    I would appreciate any help. Could there be other settings that are wrong?

    Sincerely,
    Viktor

    https://wordpress.org/plugins/responsive-lightbox/

  2. dFactory
    Member
    Plugin Author

    Posted 2 months ago #

    Nice portraits, congratulations :)

    When in comes to the issue. I see that your images have alt attribute only. There should be image title or link title set to make use of it in display.

  3. Arno Welzel
    Member
    Posted 2 months ago #

    For the the "Swipebox" script this problem is already solved - it will use the alt attribute if there is no other title available.

    So if you change to "Swipebox" it should do as well.

  4. Zaphi
    Member
    Posted 2 months ago #

    Thanks! :)

    I use "Title" and "Alt text". Still does not show. If I use Caption it just comes up under the thumbnail in the gallery, not when showin the image.

    I have:

    Title (I use this!) - Is this the "image title" ?
    Caption (empty)
    Alt text (I use this!)
    Description (empty)

    Then I have Gallery Link URL etc. I can't find any option for "link title" or "Image title".

    Am I doing it wrong or is there some other problem?

  5. Arno Welzel
    Member
    Posted 2 months ago #

    That's why I suggested using ANOTHER lightbox script in the Plugin. You can change to "Swipebox" and this will use the "alt" attribute if available.

    Example:

    http://arnowelzel.de/wp/en/paris-2012

    This uses Responsive Lightbox with "Swipebox" script and "Cleaner Gallery" (http://wordpress.org/plugins/cleaner-gallery/) for the gallery output.

    But the "Swipebox" also works fine for single images without description but a title in the "alt" attribute, see:

    http://arnowelzel.de/wp/en/raspi-dish

  6. Zaphi
    Member
    Posted 2 months ago #

    Oh ok! Well, I am not sure how to change that script. I do not know much about editing and customizing WordPress and it's plugins. Where do I get this script and how do I change it?

    Anyway, Responsive Lightbox worked fine before, but hasn't for a few months now. I have made no changes to what I did before and titles to the older photos in the blogg don't work either.

    @dFactory: My images DO have an image title set. At least in WordPress gallery admin...

  7. Arno Welzel
    Member
    Posted 2 months ago #

    To change the script being used, just go to the general settings for Responsive Lightbox in your WordPress backend (Settings - Responsive Lightbox) and select "Swipebox" in the first option "Lightbox script" (see the screenshot at http://arnowelzel.de/samples/responsive-lightbox-options.png).

    I did not check this thoroughly yet - but as far I know the other scripts "prettyPhoto", "FancyBox", "Nivo Lightbox" and "Image Lightbox" may need a separate caption or description element, so a "title" or "alt" attribute in the image element may not be enough.

  8. jwhittaker99
    Member
    Posted 1 month ago #

    Further to this I can confirm that prettyPhoto will use the caption text for both the caption and title, even if you have something different in the title field. It uses the Alt Text field for the title. Haven't tried the other scripts.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags