WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Titles & Meta page is blank (2 posts)

  1. sgwatwp
    Member
    Posted 1 year ago #

    My problem is that when I click the "Titles & Metas" subsection of the SEO plugin the page is loaded, with the menu bar across the top listing "General, Home, Post Types, ect..." but nothing displays below, even when clicking the menu buttons.

    I checked the html and it seems that all the divs with the class "wpseotab" are styled as "display: none" currently. I see in the javascript that's the default and when you click a menu button that is changed - the class that is.

    Here is the section of code I'm referring to.

    var active_tab = window.location.hash.replace('#top#','');
    	if ( active_tab == '' )
    		active_tab = 'general';
    	jQuery('#'+active_tab).addClass('active');
    	jQuery('#'+active_tab+'-tab').addClass('nav-tab-active');
    
    	jQuery('#wpseo-tabs a').click(function() {
    		jQuery('#wpseo-tabs a').removeClass('nav-tab-active');
    		jQuery('.wpseotab').removeClass('active');
    
    		var id = jQuery(this).attr('id').replace('-tab','');
    		jQuery('#'+id).addClass('active');
    		jQuery(this).addClass('nav-tab-active');
    	});

    I've read other topics about people having this problem but I decided to start a new one because

    • I'm not using any of the conflicting plugins they mentioned
    • I tried deactivating and activating again.
    • When I manually inject the jquery found in wp-seo-admin.js into the page through Chrome's console, everything appears
    • I'd be willing to track down this problem myself if I could get a little direction
    • So I was wondering where in the plugin the above listed .js file is loaded in (wp-seo-admin.js) because it doesn't appear to be loaded when I request admin.php?page=wpseo_titles. Or something about this section is just not firing.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. sgwatwp
    Member
    Posted 1 year ago #

    Does anyone have any idea where this .js file is loaded in?

    There seems to be some javascript problem going on because the rest of my dashboard menu items (on the left side of the screen) won't expand when I hover over them.

    This only happens when I am on one of the menu pages for the WordPress SEO plugin. If I'm on any other page of my dashboard, the dashboard menu items function correctly.

    There has to be some javascript problem with wordpress SEO. I'm willing to try and figure it out but I'd like to know where to start. In which file are all the .js files enqueued?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic