WordPress.org

Ready to get started?Download WordPress

Forums

Title update in media library not reflected on posts and pages (12 posts)

  1. Greg0497
    Member
    Posted 1 year ago #

    Hi,
    I've noticed that when I update the name title or the alt text of a picture in media library, the new name or new alt text don't get reflected in pages and posts using this picture.
    Is it normal?
    Is there a way to get titles and alt text updated on pages and posts to reflect the new wording?
    Many thanks,

  2. CarolineElisa
    Member
    Posted 1 year ago #

    I'm also wondering the same thing...

  3. deepbevel
    Member
    Posted 1 year ago #

    That's not normal, Although I didn't test it with an image uploaded direct to the media library, then attached or embedded in a post after. I wouldn't think it would matter.
    Does the image file in the media library have the same attachment id as the one in the post or page? Sometimes you can end up with duplicates and not know which you are editing.

  4. deepbevel
    Member
    Posted 1 year ago #

    However, if you embed image code in a post or page, the embedded code does not change after you update the image settings, so you have to go back to the post or page and re embedd the code with the new changes.

  5. deepbevel
    Member
    Posted 1 year ago #

    If using the images in a wp gallery, they are generated dynamically and so the changes will be reflected.

  6. CarolineElisa
    Member
    Posted 1 year ago #

    Bad news as I just spent a bunch of hours updating alt text through the media library... but thanks for clarifying!

  7. deepbevel
    Member
    Posted 1 year ago #

    ouch, well, you won't forget it next time!
    if possible I use galleries instead of embedding for that very reason.

  8. Jaabie
    Member
    Posted 1 year ago #

    So just clarify for the thickies like me:

    Updating the media library DOES NOT update an embedded image in a post or page!!!!!! Grrrrrrrrhaa!

    I uploaded 1170 images into my media library embedded them in to numerous posts, then discovered they all need to be SEO'ed by including the Alt. text on all images.

    I can either update the image directly in the post (BUT the corresponding image in the media library will not change).

    OR

    Update the files in the media library then RE-embed them into all my posts ?

    Is there any plugins out there to fix this issue? IE to force the embedded images to take the media library attributes?

    ShutterLIVING.com

  9. deepbevel
    Member
    Posted 1 year ago #

  10. CarolineElisa
    Member
    Posted 1 year ago #

    Thanks deepbevel!

    So we can filter get_image_tag to change the alt text.

    Anyone have an idea if it is possible to make it pick up the alt text from the media library?

  11. deepbevel
    Member
    Posted 1 year ago #

    here's another lead, sorry I don't have time to test this stuff right now. but it's out there.
    http://wordpress.org/support/topic/get-title-alt-or-caption-from-media-library-and-insert-into-theme?replies=8

  12. deepbevel
    Member
    Posted 1 year ago #

    nope, that doesn't apply to this issue, so sorry.

Topic Closed

This topic has been closed to new replies.

About this Topic