WordPress.org

Ready to get started?Download WordPress

Forums

Oxygen
Title length - images above blog posts - blogroll (4 posts)

  1. esellek1
    Member
    Posted 11 months ago #

    hi

    I have had my blog on wordpress.com (esellek.wordpress.com) and have taken the plunge and moved to my own hosting here on wordpress.org (esellek.com/blog).

    I am having trouble with a couple of things:

    Blog title
    Wordpress.com - my title goes across the page
    Wordpress.org - my title is wrapping.

    I have tried to fix this with the css putting width to 100% but it still isn't going all the way along so I guess I am missing something?

    Images
    My images that go above the blog posts, I am having to manually go into each post and set a featured image. On WP.com I didn't have to do this, it seemed to just pick up the first picture. Is there something in css that I need to change or do I have to do what I have been doing and fixing this manually?

    I can't find where to get the blogroll. There is a widget for links on wp.com but is there one on wp.org? I've gone blind looking and can't figure this out having spent hours yesterday trying to fix the title etc!!

    Thanks in advance for any help.

  2. Sridhar Katakam
    Member
    Posted 11 months ago #

    1) Add the following at the end of theme's style.css (WP dashboard -> Appearance -> Editor):

    #branding {
        width: auto;
    }

    2) Edit index.php

    Replace

    get_the_image( array( 'meta_key' => 'Thumbnail', 'size' => 'archive-thumbnail', 'image_class' => 'featured', 'width' => 470, 'height' => 140, 'default_image' => get_template_directory_uri() . '/images/archive-thumbnail-placeholder.gif' ) );

    with

    get_the_image( array( 'meta_key' => 'Thumbnail', 'image_scan' => true, 'size' => 'archive-thumbnail', 'image_class' => 'featured', 'width' => 470, 'height' => 140, 'default_image' => get_template_directory_uri() . '/images/archive-thumbnail-placeholder.gif' ) );

    3) http://codex.wordpress.org/Links_Manager

  3. paulwpxp
    Font hero
    Posted 11 months ago #

    blog on wordpress.com ..and moved to my own hosting

    If not already yet, go to the one at wp.com, under Settings -> Reading , make sure you set it to "Discourage search engines from indexing this site".

    And of course, make sure the self-hosted one is set otherwise.

    Blog title

    Under Custom CSS provided by your Jetpack plugin, put this in

    #branding {
    	float: none;
    	width: auto;
    }

    and remember not to drag widget into the header sidebar.

    Just an idea though, your site title is long but it's divided into 3 verses, you could fine tune it to have proper font size/ letter spacing so that it wraps nicely in certain screenwidths using media query.

    Images

    Oxegen comes pre-installed with Get The Image plugin and it is used in that section, however the automatically pulling first images presented in the post is off by default.

    But if you upload image directly to that post, image would attach to (become child of) that post. In this case Get The Image will pull this image automatically, if it doesn't, there is something wrong.

    blogroll

    Go to menu and create one ( you could create as many set as you want )
    http://codex.wordpress.org/WordPress_Menu_User_Guide

    Then head over to widgets and drag Custom Menu widget into the sidebar and choose that menu to appear in.

  4. esellek1
    Member
    Posted 11 months ago #

    Thank you, will give these a go :)

Reply

You must log in to post.

About this Theme

About this Topic