WordPress.org

Ready to get started?Download WordPress

Forums

All in One SEO Pack
[resolved] Title and Description Meta Tags do not show up using All in One Seo Pack Plugin (13 posts)

  1. fabiorenna
    Member
    Posted 1 year ago #

    Hello,

    I'm having an issue concerning the correct visualization of Title and Description Meta Tags using the All in One Seo Pack Plugin.
    I'm running a multilingual website (ITA, ENG) and I'm using the All in One Seo Pack plugin to write down meta title and meta description for each post (in both languages).

    As I can see, the meta title is correct in both languages, but I noticed that the meta description doesn't show up in any way (nor italian, or english): maybe an example is better.

    Example Page (ITA)
    meta title (ok, it works fine for both languages): "Example Page Italian Title"
    meta description (doesn't show up when I search through Google, for instance): "Example page italian description that doesn't show up"

    Using Firefox, if I right click > view (html) page source I can see in the head section:

    <meta name="description" content=" » Page Title | Tagline" /> (THIS is the content that all search engines show up, instead of my meta description)

    and, lower in the page:

    <!– All in One SEO Pack 1.6.15.3 by Michael Torbert of Semper Fi Web Design[44,98] –>
    <meta name="description" content="Example page italian description that doesn't show up" />

    Do you please have any suggestions about this?
    It's really important due to a SEO job.
    Thanks for your kind attention, best regards

    http://wordpress.org/extend/plugins/all-in-one-seo-pack/

  2. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    fabiorenna,

    The latest version of All in One SEO Pack has better support for WPML, if you're using that on your site; so consider upgrading.

  3. fabiorenna
    Member
    Posted 1 year ago #

    Hi,
    thanks for your reply.
    I'll consider it for sure, but first I'd like to see the plugin in action :)
    Is there any chance I can use a little help?
    Best regards

  4. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    I'm afraid I don't understand what you mean; that is how you'd see the plugin in action -- by using it.

  5. fabiorenna
    Member
    Posted 1 year ago #

    Hello,
    I'm sorry: I misinterpreted your words thinking you were referring to paid support (by the way, I'm considering it for other questions).

    I got the latest version few days ago, but as I can see the problem persists.

    Please, let me know if you need any further informations to better understand the situation.

    Thank you for your kind support,
    Best regards

  6. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    fabiorenna,

    Are you using WPML on your site? If so, you might be able to contact their support about this as well. What I believe it does is create them each as separate posts, one in English and the other in Italian, and then manages that for you. Yes, these are the kinds of issues we troubleshoot for our Pro customers, and to help fix bugs for new features.

  7. fabiorenna
    Member
    Posted 1 year ago #

    Hi,

    yes I'm using WPML on my site. I have already contacted their online support, but they told me - in a nutshell - that my problem is due to the use of All in One Seo Pack Plugin with WPML (but I found an article on their website claiming that AIOSP 2.0 works fine with WPML).
    It's strange, isn't it? I don't know what to do: I'm thinking about leaving AIOSP for Yoast, but I'd prefer not to :(
    Can you please give me any suggestion?
    Thank you again,
    best regards

  8. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    fabiorenna,

    If this is actually a bug in the plugin, then I'd like to get it troubleshooted; go to All in One SEO -> Performance, and scroll down to the bottom of the System Status area. You should see a box for E-mailing debug information. Enter support AT semperfiwebdesign DOT com as an email address into that field and click Submit, and that should give me the information I need to troubleshoot this; that will send us a copy of all your system status information there.

  9. fabiorenna
    Member
    Posted 1 year ago #

    Hi,

    thank you so much, I just send you the e-mail you request.

  10. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    fabiorenna,

    I've tested a similar setup on a test site with WordPress in Italian, All In One SEO Pack 2.0, WPML version 2.5.2 beta 3, and Theme 1299 (by the same developer I believe). WPML works, and I see on your site that All In One SEO Pack is generating descriptions and keywords properly. It looks like your theme is addding its own keywords and description meta tags; you'll want to remove those from your header.php, they don't need to be there. And for WPML, I assume you're editing content for alternate languages by going to "Mostra contenuti in:" at the top of the "Tutte le pagine" screen and selecting the appropriate language. All in One SEO Pack is compatible with this, and that is how you may set Titles, Descriptions, and Keywords in different languages.

  11. fabiorenna
    Member
    Posted 1 year ago #

    Hi,

    thank you so much for your suggestions: I removed the description meta tag from the header.php file of the theme I'm using.
    Do you think the change should be applied immediately? At the moment I can't see any diffeerence. I'll wait and see :)
    Best regards

  12. Peter Baylies
    Member
    Plugin Author

    Posted 1 year ago #

    fabiorenna,

    I doubt it'd change immediately, but you might be able to go into Google Webmaster Tools to check on it.

  13. fabiorenna
    Member
    Posted 1 year ago #

    Hello,
    thank you again for your kind assistance: I'll wait and see ;)
    Best regards

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic