WordPress.org

Ready to get started?Download WordPress

Forums

Titan Theme Featured Image not working (4 posts)

  1. AthensWebStudio
    Member
    Posted 3 years ago #

    I am using the titan theme which has the option to add a featured image for each page; however, when I change the image and upload the page I still get the default image.

    The Featured Image option is located in the sidebar for the page; set featured image pulls up the media library. From there I can select the correct sized image and instead of inserting into post I have the option to 'use as featured image'. I save the file and get the default image.

    Contacted the Titan folks; unfortunately they don't provide support for non-pro users. Since I work at a non-profit university, that isn't an option for me.

    Here is the code for the sidebar:
    <div id="sidebar">
    <?php if ($titan->sideboxState() != 'true' ){ ?>
    <div id="sidebox">
    <?php if ($titan->sideboxCustom() == 'true' ): ?>
    <?php echo $titan->sideboxCode(); ?>
    <?php else : ?>
    <img src="<?php bloginfo( 'template_url'); ?>/images/sidebar/sidebox.jpg" width="236" height="236" alt="Titan WordPress Theme" />
    <?php endif; ?>
    </div><!--end sidebox-->

  2. kidsvotingnsv
    Member
    Posted 3 years ago #

    AthensWebStudio - did you figure out a solution to your problem. I'm having the same issue as well. I did change the code to pull one of my images instead of the default. But I would like for it to pull a different feature image for each page as it's intended to do.

  3. AthensWebStudio
    Member
    Posted 3 years ago #

    Unfortunately, I did not. I too was able to put in a static image but wanted a different feature image for each page. I wrote to the folks who designed the template and the only advice was to reinstall the theme. Had already done that to make sure it wasn't something I had done on my end. They want you to pay for the right to read their forum. I work for a university and so that isn't possible for me.

    Best of luck in figuring it out.

  4. AthensWebStudio
    Member
    Posted 3 years ago #

    I found a workable solution to the problem. I disabled the sidebar sidebox under Titan options. Installed the featured image widget [http://wordpress.org/extend/plugins/featured-image-widget/], then placed it in the sidebar via the widgets option. You can adjust the size of the image there [small, medium or large] as well.

Topic Closed

This topic has been closed to new replies.

About this Topic