WordPress.org

Ready to get started?Download WordPress

Forums

Magic Fields
TinyMCE Visual/HTML toggle doesn't work on WP3.1 + Magic Fields 1.5.3 (57 posts)

  1. figureone
    Member
    Posted 3 years ago #

    @autumnmist, did you apply the temporary fix @hunk suggested at the top of this thread (commenting out the tinymce init line)? When I did that, I had problems with p and br tags.

  2. autumnmist
    Member
    Posted 3 years ago #

    I tried it and then undid it and I still have problems with p and br tags no matter whether it's commented out or not.

  3. figureone
    Member
    Posted 3 years ago #

    @autumnmist, at this point I'd suggest installing the TinyMCE Advanced plugin and enabling:
    Dashboard > Settings > TinyMCE Advanced > Advanced Options > Stop removing the p and br tags...

    http://wordpress.org/extend/plugins/tinymce-advanced/

    See if that makes a difference.

  4. hotgluemedia
    Member
    Posted 3 years ago #

    I wonder if @autumnmist's issue isn't related to mine - if the Visual/HTML toggle isn't properly toggled (and not noticed/manually pressed before publishing/updating the post/page), the format stripping is the end result.

    @autumnmist, are you noticing a toggle issue at all?

  5. autumnmist
    Member
    Posted 3 years ago #

    I noticed a format/toggle issue when I apply the line:1198 patch, weirdly enough, which is why I thought my problem might be related. If it isn't, I'll make another thread.

  6. jdkoelsch
    Member
    Posted 3 years ago #

    I am also having an issue with a textarea not saving if the visual editor is used for the field. I do not have duplicates in my wp_mf_panel_custom_field table. Rather than implement the patch, I checked "Hide Visual Editor for this field" for now, which seems to solve the problem. It's not ideal, but it works for now.

  7. hunk
    Member
    Plugin Author

    Posted 3 years ago #

    Hi all.

    I made some changes to try to fix this. here devel brach https://github.com/hunk/Magic-Fields

    I have added the option to not remove tags (br and p).

    settings->Magic Fields http://img.skitch.com/20110415-b279rjg7pwp56t7h9r4e69tk4c.png

    in post/page http://img.skitch.com/20110415-mkm4e82s1rp3f3k8p7tk2cn351.png

    in the front-end http://img.skitch.com/20110415-nmi1phif23uachr2mkr1gxyygu.png

    if you can test this version and tell me if everything works properly. thanks

  8. autumnmist
    Member
    Posted 3 years ago #

    Is it going to cause problems if I am running MF 1.5.4 and the changes are to MF 1.5.2?

  9. hunk
    Member
    Plugin Author

    Posted 3 years ago #

    No. the github es the current version (1.5.4) + bugfixes.

  10. autumnmist
    Member
    Posted 3 years ago #

    Weird am I doing something wrong (I don't know git very well)? When I hit download zip, I get a file "hunk-Magic-Fields-v1.5.2-22-gc2afd1a.zip".

  11. autumnmist
    Member
    Posted 3 years ago #

    Ok, well I guess when I install it on WordPress it seems to be ok (1.5.4), but when I click on my Custom Post panels, even though the posts are still there (it knows that there are 27 posts for one type), none of them are being displayed.

  12. hunk
    Member
    Plugin Author

    Posted 3 years ago #

    Yes, the wordpress read the value in Main.php had not placed the latest version for github

  13. hunk
    Member
    Plugin Author

    Posted 3 years ago #

    autumnmist en manage of write panel?

  14. autumnmist
    Member
    Posted 3 years ago #

    @hunk Sorry I don't understand what you were trying to say.

  15. hunk
    Member
    Plugin Author

    Posted 3 years ago #

    where no display

  16. autumnmist
    Member
    Posted 3 years ago #

    I have some custom posts with corresponding custom post write panels (examples: "Faculty", "Students"). When I click on Students > Manage, I usually see a page listing all the posts that were created using the Students write panel. But when I install the patched Magic Fields, I click "Manage" and I see nothing listed.

    See here:
    https://skitch.com/autumnmist/r4t7a/mfpbrissues1

  17. hunk
    Member
    Plugin Author

    Posted 3 years ago #

    Try reactivate the plugin (disable and enable). also activate WP_DEBUG

  18. autumnmist
    Member
    Posted 3 years ago #

    Reactivating plugin didn't help. I activated WP_DEBUG and I get:

    WordPress database error: [Unknown column 'wp_postmeta.post_id' in 'on clause']
    SELECT SQL_CALC_FOUND_ROWS wp_16ztI55qJ_posts.* FROM wp_16ztI55qJ_posts JOIN wp_16ztI55qJ_postmeta ON wp_postmeta.post_id = wp_posts.ID WHERE 1=1 AND wp_16ztI55qJ_posts.post_type = 'post' AND (wp_16ztI55qJ_posts.post_status = 'publish' OR wp_16ztI55qJ_posts.post_status = 'future' OR wp_16ztI55qJ_posts.post_status = 'draft' OR wp_16ztI55qJ_posts.post_status = 'pending' OR wp_16ztI55qJ_posts.post_status = 'private') and wp_16ztI55qJ_postmeta.meta_key = '_mf_write_panel_id' and wp_16ztI55qJ_postmeta.meta_value = '2' ORDER BY wp_16ztI55qJ_posts.post_date DESC LIMIT 0, 50

  19. hunk
    Member
    Plugin Author

    Posted 3 years ago #

    OK, autumnmist you can download the las version o apply this patch https://github.com/hunk/Magic-Fields/commit/137064edbd4d4995f8f4a60460e5d4b36582cd67

  20. autumnmist
    Member
    Posted 3 years ago #

    Hm still no. I deleted the old plugin, downloaded, activated, deactivated, reactivated the version you just patched but posts still don't appear. Error message is slightly different though:

    WordPress database error: [Unknown column 'wp_posts.ID' in 'on clause']
    SELECT SQL_CALC_FOUND_ROWS wp_16ztI55qJ_posts.* FROM wp_16ztI55qJ_posts JOIN wp_16ztI55qJ_postmeta ON wp_16ztI55qJ_postmeta.post_id = wp_posts.ID WHERE 1=1 AND wp_16ztI55qJ_posts.post_type = 'post' AND (wp_16ztI55qJ_posts.post_status = 'publish' OR wp_16ztI55qJ_posts.post_status = 'future' OR wp_16ztI55qJ_posts.post_status = 'draft' OR wp_16ztI55qJ_posts.post_status = 'pending' OR wp_16ztI55qJ_posts.post_status = 'private') and wp_16ztI55qJ_postmeta.meta_key = '_mf_write_panel_id' and wp_16ztI55qJ_postmeta.meta_value = '2' ORDER BY wp_16ztI55qJ_posts.post_date DESC LIMIT 0, 50

  21. hunk
    Member
    Plugin Author

    Posted 3 years ago #

  22. autumnmist
    Member
    Posted 3 years ago #

    Yay! Posts show up and in some quick testing, it looks like p and br aren't being removed anymore and I can flip between Visual and HTML tabs properly. Thanks!!

  23. mattcooperinlondon
    Member
    Posted 3 years ago #

    Hi

    Did we get anywhere with the original problem of content disappearing when toggling between 'HTML' and 'Visual'?

    The quick fix (commenting 1198) doesn't solve things for me as I need to be able to add images into the multi-line text box.

    Sorry if i missed something, but it seems that the thread moved around a lot.

    thanks

    p.s. love the plugin, it's vital to all the WP development i do so thanks for you ongoing work

  24. dragondance
    Member
    Posted 3 years ago #

    hey guys,
    I have the same question as mattcooperinlondon. For me, in some cases, the "HTML" and "Visual" buttons just don't do anything when clicked. The quick fix (commenting line 1198) makes the buttons work, but the media buttons disappear.
    I tried the latest version on https://github.com/hunk/Magic-Fields, it did the same as the quick fix (the toggle buttons work, but the media buttons disappear)
    Please help.

    I love the plugin, too, thank you.

  25. figureone
    Member
    Posted 3 years ago #

    If you're using the latest version from github (which includes the quick fix on line 1198), you should have the media buttons, but they'll now be in the TinyMCE toolbar (usually 4 grayish buttons at the far right of the top row) instead of above the TinyMCE toolbar. Can you check on that?

  26. dragondance
    Member
    Posted 3 years ago #

    @figureone: yes, thanks very much. Last time I tried, I didn't see the media buttons because they were moved into the TinyMCE toolbar.
    Again, thanks for the great plugin.

  27. res401
    Member
    Posted 2 years ago #

    WordPress Version 3.3.1
    This has been driving me crazy for weeks now, I have tried everything I can find so far, disableing the wpautop() function, tinymce advanced plugin, etc.

    The only thing I found that worked was to create this: http://rich-stadnick.com/2012/02/wp-br-tags-fix-wordpress-from-auto-correcting-your-post-format/
    What WP BR Tags does is allow you to insert “Short-Code’s” instead of “html” codes, and NEVER AGAIN will you have to worry about WordPress removing br tags.

    Hope it help's you guys out.
    Rich

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic