WordPress.org

Ready to get started?Download WordPress

Forums

tinyMCE undefined (7 posts)

  1. Streetwise
    Member
    Posted 8 years ago #

    I just did an upgrade on my blog on a test server. It seems to work fine except that whenever I log into the dashboard, I notice a small yellow triangle in the lower left browser window (IE) and either 'Done', or 'Done but with errors', or sometimes 'error'.

    It only happens on the 'Write' and 'Manage' tabs as follows:

    'Write/Write Post' tab:

    Line: 502 (sometimes it's '494')
    Char: 1
    Error: 'tinyMCE' undefined
    Code: 0
    URL: http://www.myblog.com/wp-admin/post.php

    'Write/Write Page' tab:

    Line: 371
    Char: 1
    Error: 'tinyMCE' undefined
    Code: 0
    URL: http://www.myblog.com/wp-admin/page-new.php

    'Manage/Posts' tab:

    Line: 156
    Char: 87
    Error: expected 'j'
    Code: 0
    URL: http://www.myblog.com/wp-admin/edit.php

    Sometimes, a quick refresh will make the errors go away, sometimes not. Those are the only tabs that seem to be problematic.

    'Links' tab:

    Page load initially would go into some type of loop with a reload. Now all it does is produce a "Page cannot be displayed" error...

    These are the only issues I've found so far. Any help would be appreciated.

    WinXP Pro
    Apache 2.0.55
    PHP 4.4.1
    MySQL 4.1.16

  2. dthought
    Member
    Posted 8 years ago #

    I noticed this as well. It appears to be that they're sending the JS file via Gzip... and IE simply won't decode it properly. I would presume their Gzip libraries are borked, because IE usually does Gzipped stuff just fine.

    Here's a quick fix:

    Open up wp-admin/admin-header.php

    Find the lines
    <?php if ( $editing && user_can_richedit() ) : ?>
    <script type="text/javascript" src="../wp-includes/js/tinymce/tiny_mce_gzip.php?ver=20051211"></script>
    <?php endif; ?>

    Replace with

    <?php if ( $editing && user_can_richedit() ) : ?>
    <script type="text/javascript" src="../wp-includes/js/tinymce/tiny_mce.js"></script>
    <?php endif; ?>

    Oh, and whilst you're at it, feel free to go into admin-functions.php and comment out lines 1589 - 1596. Filthy BrowseHippy scum. Snidely suggesting that people change browsers is inappropriate on people's sites. If WP want to put it on their own site, so be it, but they should not force their propaganda onto others. If you aren't totally clueless with security patches and randomly accepting plugin downloads, IE is just fine. If you are good at what you do, you write conditionals to work around IE issues... so then everyone can view your work. That's what it's all about.

  3. Matt Mullenweg
    Troublemaker
    Posted 8 years ago #

    Under Options > Reading there is an option:

    [ ] WordPress should compress articles (gzip) if browsers ask for them

    Uncheck this if you would like TinyMCE not to be gzipped.

  4. Starbuck
    Member
    Posted 8 years ago #

    Just a follow-up for posterity here: I recently installed WP2.0 and have been adding plugins. One of them seemed to have induced the error described here. I deactivated all plugins and the error persisted. I edited the admin-header as described here (saved the original and added a new line) and it's working now. Something caused this to break, I'm curious what it was. I'll post here if I get a clue. (Story of my life.)

    BTW Mike, I've been meaning to get rid of that little IE slander, thanks for reminding me. :)

  5. halinagold
    Member
    Posted 8 years ago #

    I've had a similar problem and none of the suggested helped. After trying this and that I finally deleted the whole wp-admin folder from the server and then uploaded a fresh copy. This did the trick.

  6. waschbecken
    Member
    Posted 7 years ago #

    I also tried to fix my "undefined" problem but it still exists after the admin-header.php mod. But the tinymce problem only occurs using IE6. With FF, IE7, Mozilla everythins works fine.
    Any further hints?

  7. Dave Kaufman
    Member
    Posted 7 years ago #

    Ok...I had to post this...I have been searching for how to bring back the tinyMCE Editor for a few days now. Tried all the regular tricks (delete everything and reinstall).

    So I tried @dthought post. Nothing. I figured I wanted to keep searching with a "clean" install so I reverted back to the original line, and I see the WYSIWYG Editor. Odd!

    Just posting for those who are searching the forums.

Topic Closed

This topic has been closed to new replies.

About this Topic