WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] TinyMCE theme:"skin:"wp_theme", removed from WP3.3 ? (5 posts)

  1. Thomas
    Member
    Posted 2 years ago #

    Hi guys,
    looks like any plugin or theme that includes the tinyMCE editor in their option panel does not work in 3.3Beta when using: skin:"wp_theme",

    The tinyMCE editor does seem to work when changing it to: skin:"default",

    Any chance to have backwards compatibility for skin:"wp_theme", in WordPress3.3 ? Anyone else seeing this?

  2. Andrew Ozz
    WordPress Dev
    Posted 2 years ago #

    This is caused by separating the MCE's wp_theme styles in editor-buttons.css which is included when using the new wp_editor() function/API in 3.3. Try using that, it makes it a lot easier.

    Perhaps we can put the MCE button styles back in the "advanced" theme and let the editor load them (although that would mean loading one more stylesheet at the end of the page load, i.e. slowness). That would make it back-compat for plugins that use tiny_mce.js directly.

  3. Thomas
    Member
    Posted 2 years ago #

    @ Andrew
    Thank you for your reply.

    I will do that going forward.
    I am wondering how many plugins and themes are affected. Having the backwards compatibility would be sure awesome :-)

    Thank You again.

  4. Andrew Ozz
    WordPress Dev
    Posted 2 years ago #

    Fixed (after RC) thanks to @nacin. Should be fully backwards compatible now even if plugins load tiny_mce.js directly (and use the wp_theme skin of course).

  5. Thomas
    Member
    Posted 2 years ago #

    You guys are the best!
    I truly appreciate what you guys are doing.
    Thank You!

    Thomas

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.