WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] TinyMCE problem with wordpress 2.9.2 (20 posts)

  1. stroohead
    Member
    Posted 4 years ago #

    I'm having problems with the editor in WordPress. It doesn't show the HTML/Visual tabs or any of the Visual buttons (obviously) and I can only edit in HTML mode. It looks like this.

    I've read through all the forum threads that looked like they where addressing the same issue but nothing worked. I've also tried all the basic stuff, like disabling plugins, download a new wordpress and uploading it, nothing worked.

    Any ideas?

  2. stroohead
    Member
    Posted 4 years ago #

    I seem to have the same problem as this person. The topic seems to be resolved, but no solution is posted :S

  3. henkholland
    Member
    Posted 4 years ago #

    Try re-uploading wp-includes through FTP.

    Next, it could be a server memory problem. Try adding this to your wp-config.php on a new line right after db_collate:
    define('WP_MEMORY_LIMIT', '64M');

  4. stroohead
    Member
    Posted 4 years ago #

    Thanks for your efforts Henk. I was really hoping the memory limit would work, but no go. Still the same problem.

    I've deleted and re-uploaded the wp-includes folder AGAIN, but still the same problem. It's driving me insane. Any other suggestions?

  5. stroohead
    Member
    Posted 4 years ago #

    Gears is off, I've tried diffrent browsers, nothing :(

  6. henkholland
    Member
    Posted 4 years ago #

    Just a thought: did you check Dashboard/Users/Profile The top line there has the tickbox for Allowing Visual Editor.

  7. tolipoc
    Member
    Posted 4 years ago #

    I'm having a similar problem (Version 2.9.2). When I try to write a new post the text is white. I can't switch between visual / html mode. Plus I can't upload any images or add tags. I get a lot of JavaScript errors "Tiny MCE is not defined" for example.

  8. henkholland
    Member
    Posted 4 years ago #

    Tolipoc,

    Try this first:
    Try re-uploading wp-includes through FTP.

    Next, it could be a server memory problem. Try adding this to your wp-config.php on a new line right after db_collate:
    define('WP_MEMORY_LIMIT', '64M');

  9. hello
    Member
    Posted 4 years ago #

    stroohead,

    I was having the same problem. I finally fixed it by removing an .htaccess file that I had placed in the wp-includes folder for security reasons. If you placed an .htaccess file there for security reasons, try removing it. This is what was in my file:

    Order Allow,Deny
    Deny from all
    <Files ~ ".(css|jpe?g|png|gif|js)$">
    Allow from all
    </Files>

    It's great for security so I will just add it back when I finish editing. Hope this helps.

  10. phwdennis
    Member
    Posted 4 years ago #

    I'm having the same or similar problem and none of these suggestions solved the problem for me. When trying to edit or add a new page or post, sometimes the editor doesn't come up, not at all. I get the sidebar status information but not the WYSIWYG editor.

    I've tried all the following in various orders:

    * Clearing my browser cache
    * Rebooting
    * Clearing Google Gears cache
    * Installing Dean's FCKEditor plugin
    * Completely deleting and then re-uploading by FTP the wp-includes directory freshly unzipped from the 2.9.2. zip file
    * Trying different browsers (Firefox and Chrome)
    * Deleting .htaccess file (I didn't have one)
    * Adding define('WP_MEMORY_LIMIT', '64M'); to my wp-config.php file

    The problem persists. Any other suggestions?

  11. henkholland
    Member
    Posted 4 years ago #

    Contact your host about raising the memory limit

  12. sissco
    Member
    Posted 4 years ago #

    I am having basically the same problem, except now I am unable to log into my wp-admin, I get this error:

    Warning: Cannot modify header information - headers already sent by (output started at /home/onlyme/public_html/reviews/wp-content/plugins/all-in-one-seo-pack/aioseop.class.php:4466) in /home/onlyme/public_html/reviews/wp-includes/pluggable.php on line 868

    I need to get into the dashboard so that I can deactivate the seo-pack, I think that this is what is causing the problem, and when I am done, I can reactivate it. Any idea on how I can access the wp-admin?

  13. Larske
    Member
    Posted 4 years ago #

    I also have this problem, except that mine is a little bit different. When i try to edit an existing message or page the above desribed problem occurs. But when i create a new message or page the wysiwyg option works fine.

    I have tried everything that is advised in this topic but nothing works out.

    Hope someone knows how to solve this..

  14. teo7
    Member
    Posted 4 years ago #

    Try deactivating all plugins. If problem solves, then activate plugins one by one to know which one is causing the problem.

  15. fabe
    Member
    Posted 4 years ago #

    I had the same Problem, solved it by upgrading to PHP 5, using a Parse-Request(?) in the .htaccess. - just two lines of code:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    I've been putting them at the End of .htaccess, if you don't have such a file you can easily create one with any kind of Texteditor. Then put it in the main WP-Directory using FTP.

    Here's where I found this Solution http://www.mbdealer.de/error-500-internal-server-error-bei-wordpress-2-8-x-und-11-als-webhoster - don't know if it works allways, but it did in my case. It also fixed a returning Error 500 - Problem I've been encounting, now everything's back to normal.

  16. bctv
    Member
    Posted 4 years ago #

    If you have the Meebo social plugin installed on your website, the following code will cause the wysiwyg editor to disappear:

    <script type="text/javascript">
    Meebo('domReady');
    </script>

  17. dirkweiss
    Member
    Posted 4 years ago #

    Possible Solution:

    The dissaperance of my WYSIWYG editor was due to improper permissions on the wp-includes folder. They were set to 700 (owners only read/write/execute) but need to be 750 (Owners read/write/execute + Group Read/Execute).

    Try setting the permissions for the folder only to 750.

  18. pariahdesign
    Member
    Posted 4 years ago #

    This just happened to me while using Firefox 3.6.3 on a fresh install WP 2.9.2 dashboard. I went to media to delete three image files, after doing that the icons/buttons disappeared. I switched to Explorer 8 and all the icons were there. Switched back to Firefox, still missing.

  19. Try clearing Firefox's cache.

  20. pariahdesign
    Member
    Posted 4 years ago #

    Thanks for the suggestion, macmanx. Clearing the cache did nothing. However, I noticed another checkbox for "site preferences", checked and cleared that, and now the icons/buttons are working again.
    Tools --> Clear Recent History --> (select Everything), check Site Preferences

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.