WordPress.org

Ready to get started?Download WordPress

Forums

Tinymce not showing (8 posts)

  1. losgaz
    Member
    Posted 10 months ago #

    I have been using the Exec-php plugin for several years with the visual editor disabled. I am now using shortcodes instead of the plugin which I have now removed. If I re-enable the visual editor, nothing changes except that the 'visual' and 'text' tabs are both visible and and text is now the same colour as the background. This is the same for all editors.

    I have tried disabling all plugins and using a default theme, but there is no change. I have also got the set up on a local machine and that works fine. The only difference I believe is that the exec-php plugin has never been installed. Any ideas please?

  2. Tara
    Member
    Posted 10 months ago #

    - Have you tried resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems (because the hooks remain unless plugins completely removed or some plugins stick around in cached files. So by renaming the folder, you break them and force them inactive).

  3. losgaz
    Member
    Posted 10 months ago #

    I've done all of that; even completely deleted the plugins directory. Still no change. I have also been through all the wp options and removed all entries which referred to Exec-php.

  4. Tara
    Member
    Posted 10 months ago #

  5. losgaz
    Member
    Posted 10 months ago #

    SCRIPT_DEBUG fixed the problem - the only js warning (in firefox) was

    Use of getPreventDefault() is deprecated. Use defaultPrevented instead. load-scripts:4

    When debug is off, additional warnings are

    ReferenceError: tinyMCE is not defined. (wp-includes/js/tinymce/langs/wp-langs-en.js?ver=358-25336:1)

    and

    ReferenceError: tinymce is not defined. (post.php?post=552&action=edit:1225)

    Is there any downside to running debug as a temp fix?

  6. Tara
    Member
    Posted 10 months ago #

    Try reviewing this codex: http://codex.wordpress.org/Debugging_in_WordPress

    In part, it states:

    It is not recommended to use WP_DEBUG or the other debug tools on live sites, they are meant for local testing and staging installs.

    You mentioned earlier:

    I have tried disabling all plugins and using a default theme, but there is no change.

    Have you tried:

    - If the above troubleshooting steps fail to resolve the issue, try manually re-uploading all files and folders EXCEPT the wp-config.php file and the /wp-content/ directory from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones. Read the Manual Update directions first!
    - Always backup everything (including your database) before doing any actions, just in case.

  7. losgaz
    Member
    Posted 10 months ago #

    That seems to have fixed it - a reload of the wp-includes was the one.

    Thanks a lot for your help.

  8. Tara
    Member
    Posted 10 months ago #

    Glad you got it Resolved :-)

Reply

You must log in to post.

About this Topic