WordPress.org

Ready to get started?Download WordPress

Forums

TinyMCE gone...error messages... (5 posts)

  1. BlackEagleMedia
    Member
    Posted 6 years ago #

    Our TinyMCE seems to have disapeared randomly, there was a database error earlier in the day so i'm wondering if that has anything to do with it? I get the following messages when I try to go on to the write new post page:

    Error: edToolbar is not defined
    Source File: http://www.the-dish.co.uk/wp-admin/post-new.php
    Line: 362

    Error: dbxManager is not defined
    Source File: http://www.the-dish.co.uk/wp-admin/js/dbx-admin-key.js?ver=20070417&pagenow=post-new.php
    Line: 1

    Can anyone help me get rid of this error and get our visual editor back?

  2. alexleonard
    Member
    Posted 6 years ago #

    Well, not entirely sure about this, but as a first check, please disable all plugins and see if the errors are still occurring?

    Also, what WP version are you running?

  3. BlackEagleMedia
    Member
    Posted 6 years ago #

    Version 2.3.3

    I can try disabling plugins but it seems somewhat a random error as haven't installed anything extra for a while...

  4. BlackEagleMedia
    Member
    Posted 6 years ago #

    everything else on the site seems to be working fine...just the visual editor.

    Although I am getting the following on the dashboard....

    Error: jQuery is not defined
    Source File: http://www.the-dish.co.uk/wp-admin/index.php
    Line: 16

  5. alexleonard
    Member
    Posted 6 years ago #

    I've had some problems with losing the visual editor in the past.

    Recently I caused this issue by using wp_enqueue_script in my functions.php file.

    I see you have a few extra bits of javascript being loaded at the moment on your main site - if these are being enqueued then they could cause a conflict in the admin area with prototype or something (I know very little about this by the way)...

    You have the following extra scripts running at the front end:

    <script src="http://www.the-dish.co.uk/Scripts/AC_RunActiveContent.js" type="text/javascript"></script>
    <script type="text/javascript" charset="utf-8" src="http://w.sharethis.com/widget/?wp=2.3.3&amp;publisher=a6d22ebe-91ec-4f06-bce4-816b7dbd5a0a"></script>
    <script type='text/javascript' src='http://www.the-dish.co.uk/wp-includes/js/tw-sack.js?ver=1.6.1'></script>
    <script type='text/javascript' src='http://www.the-dish.co.uk/wp-content/plugins/useronline/useronline-js.php?ver=2.20'></script>

    I don't know if one of them could be causing a problem?!

Topic Closed

This topic has been closed to new replies.

About this Topic