WordPress.org

Ready to get started?Download WordPress

Forums

TinyMCE Advanced
TinyMCE advanced not working wordpress 3.0 (5 posts)

  1. lakhotiaatul
    Member
    Posted 2 years ago #

    Hi,

    I have installed and activated the advance tiny mce plugin but I cannot see the toolbar in the editor. I have changed the settings, cleared the browser cache (and waited for a night), restarted the system couple of times, tested in IE9 and Firefox 5, but it still does not seem to be working.

    Moreover, with the plugin activated, the text in the HTML editor and Visual editor remains the same (i.e. in HTML format).

    I have seen similar posts on the forum before but none contain the solution to the problem. I am using wordpress 3.0 and have installed corresponding version of TinyMCE advanced plugin.

    Please suggest.
    Thanks

  2. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 2 years ago #

    Sounds like incomplete installation or a plugin conflict. What JS errors to you see?

  3. lakhotiaatul
    Member
    Posted 2 years ago #

    Hi,

    Thanks for the quick response. Below are the JS errors as seen via Firebug:

    a.widget.prototype._trigger is undefined
    _init()load-s...232d0af (line 81)
    Widget(a=Object { placeholder="sortable-placeholder", connectWith=".meta-box-sortables", items=".postbox", more...}, c=div#side-sortables.meta-box-sortables)jquery...ver=3.0 (line 30)
    bridge(h=Object { placeholder="sortable-placeholder", connectWith=".meta-box-sortables", items=".postbox", more...}, g=div#side-sortables.meta-box-sortables)jquery...ver=3.0 (line 28)
    Widget()jquery...ver=3.0 (line 29)
    noop(a=[div#side-sortables.meta-box-sortables, div#normal-sortables.meta-box-sortables, div#advanced-sortables.meta-box-sortables], b=function(), d=div#side-sortables.meta-box-sortables)load-s...5f803b6 (line 30)
    each(a=function(), b=undefined)load-s...5f803b6 (line 24)
    bridge(d=Object { placeholder="sortable-placeholder", connectWith=".meta-box-sortables", items=".postbox", more...})jquery...ver=3.0 (line 29)
    add_postbox_toggles(c="post", b=undefined)load-s...232d0af (line 83)
    add_postbox_toggles(c="post", b=undefined)load-s...232d0af (line 83)
    clean(e=function())load-s...232d0af (line 84)
    noConflict()load-s...5f803b6 (line 26)
    inArray()load-s...5f803b6 (line 33)
    [Break On This Error] (function(a){a.widget("ui.sortable",a...."intersect",zIndex:1000}})})(jQuery);
    load-s...232d0af (line 81)

    Please suggest..

    Thanks..

  4. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 2 years ago #

    Sounds like one of your plugins is adding a different version of jQuery or jQuery UI. That error is from UI Sortables and it should be working as expected.

    Can also try to delete the whole wp-includes directory on the server and upload a new copy from freshly downloaded and unzipped WordPress zip file for the same version you're running at the moment.

  5. lakhotiaatul
    Member
    Posted 2 years ago #

    Hi,

    I tried to replace the wp-includes with a fresh copy from wordpress and the problem still remains. I get the below JS error:

    a.widget.prototype._trigger is undefined
    [Break On This Error] (function(a){a.widget("ui.sortable",a...."intersect",zIndex:1000}})})(jQuery);
    load-s...232d0af (line 81)

    Is it related to a widget or a plugin? Currently I have Smart Slide Show plugin, Duplicate Post plugin and Contact Form 7 plugin activated. I tried to deactivate these plugins but that did not change any thing.

    I do not have much idea about PHP, so becomes difficult to debug the error.

    Please suggest..

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic