WordPress.org

Ready to get started?Download WordPress

Forums

TinyMCE Advanced
TinyMCE Advanced and classnames i the Styles drop down (3 posts)

  1. Geir F
    Member
    Posted 10 months ago #

    I have installed TinyMCE Advanced and add the Styles drop down to the toolbar. I have also created an editor-style.css and added "add_editor_style('editor-style.css');" to functions.php for my theme. So far so good.

    My editor-style.css is a simple test css that looks like this:

    .dropcap:first-letter {
        color: #0000FF;
        float: left;
        font-family: Georgia,serif;
        font-size: 48px;
        margin: 8px 10px 0 0;
    }
    
    .post-format-chat {
    	background-color: #eadaa6;
    }

    They both work as expected visually in the WYSIWYG editor if I add the tags to my blog text manually in the text mode editor. So TinyMCE apparently sees them and understands them.

    But the problem is that only the last one displays in the Style drop down that I added with TinyMCE Advanced. Why is that? My first thought is that it is related to the classname being a complex one with a colon. Is there a way to make this work?

    TIA, Geir :)

    http://wordpress.org/plugins/tinymce-advanced/

  2. Geir F
    Member
    Posted 10 months ago #

    Ok, i tried removing the first-letter qualifier from the class name, and now it displays in the list. But of course, without it I don't get the desired result when I apply it.

    Geir :)

  3. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 9 months ago #

    This is handled internally by TinyMCE. For best results set the style names directly, see http://wordpress.org/support/topic/disable-default-styles-like-wp-caption-or-alignleft-in-styles-drop-down?replies=6

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.