WordPress.org

Ready to get started?Download WordPress

Forums

TinyMCE Advanced
[resolved] TinyMCE 4.0.1 not showing on WP 3.9 (25 posts)

  1. karunaray
    Member
    Posted 4 months ago #

    Just updated WP to 3.9 followed by updating TinyMCE to 4.0.1 after it first update to 4.0

    Made no difference. Cannot even put cursor in post field, none of the icons show. Now I regret updating WP! Can't imagine posting without TinyMCE. Please advise! Did clear Firefox cache but did not restart. Tried that with 4.0 but it didn't work, then saw here that 4.0.1 was available. Doesn't work in Chrome either.

    https://wordpress.org/plugins/tinymce-advanced/

  2. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 4 months ago #

    Do you see any JS errors in the browser console? A number of bundled JS libraries were updated in WP 3.9, could be an unrelated script.

  3. karunaray
    Member
    Posted 4 months ago #

    That's a little advanced for me! Learning on the fly here. This is what I see, please help:

    uncaught exception: module definition dependecy not found: tinymce/util/Tools
    "Failed to load: http://reikihelp.com/blog/wp-admin//plugins/textcolor/editor_plugin.min.js" wp-tinymce.php:2
    "Failed to load: http://reikihelp.com/blog/wp-admin//langs/en.js" wp-tinymce.php:2
    "Failed to load: http://reikihelp.com/blog/wp-admin//plugins/charmap/editor_plugin.min.js" wp-tinymce.php:2
    "Failed to load: http://reikihelp.com/blog/wp-admin//themes/modern/editor_template.min.js" wp-tinymce.php:2
    "Failed to load: http://reikihelp.com/blog/wp-admin//plugins/hr/editor_plugin.min.js"

  4. karunaray
    Member
    Posted 4 months ago #

    Anyone? Plugin author? Never had a problem with this plugin with previous WP updates. I was just getting ready to post. I really need to post. Please provide a solution.

  5. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 4 months ago #

    That's a little advanced for me! Learning on the fly here.

    This is a good debug info :) Unfortunately it doesn't make it clear what exactly is causing these errors. Best guess is that the file wp-tinymce.js.gz has failed to update. To fix that download a fresh copy of WordPress 3.9, unzip it to a folder on your computer, then replace that file with FTP. It is wp-includes/js/tinymce/wp-tinymce.js.gz.

    Can also try to re-install 3.9, but it may fail to update that file again.

  6. karunaray
    Member
    Posted 4 months ago #

    That worked, thanks so much!

  7. susan.powers1
    Member
    Posted 4 months ago #

    I am having the exact same problem. But the fix above is a bit advanced for me. Can you explain a little more detailed what I need to do?

  8. karunaray
    Member
    Posted 4 months ago #

    Well... When you download the WP 3.9 files to your computer, they're zipped. If you right click on the downloaded folder and find unzip in the menu, you'll be able to find individual files once that's complete. Then you have to locate the one the author of this plugin mentioned above.

    After that either using an FTP program that has access to your site files on your host's server, or perhaps your host gives you access to your site files in another way, you have to upload that specific file which is found at wp-includes/js/tinymce/wp-tinymce.js.gz to your host's server in the same folder as wp-includes..., etc. However you upload it, it will ask if you want to replace/overwrite the existing file by the same name. Select yes and you're good to go.

    May need to log out of your blog and log back in or just refresh the post page so you see the visual editor.

  9. susan.powers1
    Member
    Posted 4 months ago #

    Okey dokey then.

    Thanks!

  10. xinda
    Member
    Posted 4 months ago #

    I have the same problem. I did follow your steps to replace wp-tinymce.js.gz file in /wp-includes

    I also tried to intall WP 3.9 again. Tried to deactivate the plugin and reactivate it. Tried to uninstall and install again. But non of these things worked.

    Is there something else i can try?

  11. Alexander Albrecht
    Member
    Posted 4 months ago #

    same here. did all these steps. reinstalled wp 3.9, replaced the mentioned file. nothing works. here i get a 404 on a resource not found:

    wp-includes/js/tinymce/plugins/inlinepopups/plugin.min.js

    This resource is not even on a fresh downloaded copy of WP 3.9 to be found.

  12. Sctdesign1
    Member
    Posted 4 months ago #

    I have the same problem. My site just up dated and the tinymce-advanced stop showing up in my pages edits. I was working on a clint site with a deadline what do I do?

  13. Alexander Albrecht
    Member
    Posted 4 months ago #

    Hey folks, found the problem on my pages. I've used to have some TinyMCE modding code in my functions.php which was totally unnecessary and blocked the new TinyMCE from loading. Removing that code ever<thing is fine. Now back to work.

  14. xinda
    Member
    Posted 4 months ago #

    Well in my case the problem occurs due to an error in a theme javascript file. So no problem with the plugin itself anymore.

  15. Warlib
    Member
    Posted 4 months ago #

    I just reinstall 3.9_ru, replace wp-tinymce.js.gz, uninstall/install TinyMCE Adv, but still it doesn't work. :-( There is no changes in js file in theme, no error while loading edit page.

  16. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 4 months ago #

    Yes, most of these errors are usually caused by a plugin (or some code in functions.php in the theme) that needs updating.

    To debug: switch to one of the default themes, clear browser cache, test. If still broken, start disabling plugins one by one, clearing cache and testing after each until the broken one is found.

  17. Warlib
    Member
    Posted 4 months ago #

    I already has tried to use one of the default theme, but has no success. There are quite a lot of plugins at the site and its in production. Probably there are some another way, like using debug mode or something like that?

  18. ritch47golf
    Member
    Posted 4 months ago #

    Hi,
    I have tried removing all plugins, switching themes. No luck.

    It seems to me that I am getting none of the features of 3.9. Only the very basic editor etc.

    Its a site in early development so I don't have much to remove to test things. I reinstalled 3.9 to no avail.

  19. Warlib
    Member
    Posted 4 months ago #

    I found the way to fix it. In Chrome go to Tools - Developer Tools. Then switch tool to Network. Then add new record and see either all files load properly. In my case i saw "not found" for spellchecker addon. Then I check either it exist in specified directory. No one. I remember that I had installed Yandex spellchecker plugins. I deactivate it and everything is ok now. :-) So, if someone use Q2W3 Yandex Speller - just deactivate its.

  20. holmpage
    Member
    Posted 4 months ago #

    I just went to Settings > TinyMCE Advanced and reconfigured the toolbars.

  21. RManalow
    Member
    Posted 4 months ago #

    Updated another plugin "MailPoet" (wysija) and the bug was gone.

  22. earonc
    Member
    Posted 4 months ago #

    Not all of the items in the toolbars show up on the editor (4.0). I've moved the edit image icon to the first and second toolbar, then tried to edit a post and it would not appear. other functions can be added and moved around without problem. I am unable to do things like set padding around image or wordwrap. I've recently updated to WP 3.9 and that's when the problem started.

    I removed, then added the editor plugin (did have tinymce ultimate). That was removed and tinymce advanced was added back in.

  23. SunnO
    Member
    Posted 4 months ago #

    In the developer tools I get the next error
    Uncaught TypeError: Object #<i> has no method 'add'
    tinymce.create._createButtons
    tinymce.create.init
    e
    o
    N.init
    (anonymous function)
    (anonymous function)
    o
    m
    (anonymous function)
    n

    Any ideas?

  24. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 3 months ago #

    @SunnO see what file that error comes from, that will give you a clue which WP plugin adds it. Then disable or update it.

  25. ningj123
    Member
    Posted 1 month ago #

    I have the same problem,how can i solve it ? what wp 3.9 doesn't contain this files?how can i do,help me,thanks!

    "NetworkError: 404 Not Found - http://127.0.0.1/wordpress/wp-includes/js/tinymce/themes/advanced/theme.min.js"
    theme.min.js
    Failed to load: http://127.0.0.1/wordpress/wp-includes/js/tinymce/themes/advanced/theme.min.js
    wp-tiny...0140423 (第 5 行)
    "NetworkError: 404 Not Found - http://127.0.0.1/wordpress/wp-includes/js/tinymce/plugins/inlinepopups/plugin.min.js"
    plugin.min.js
    Failed to load: http://127.0.0.1/wordpress/wp-includes/js/tinymce/plugins/inlinepopups/plugin.min.js

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.