WordPress.org

Ready to get started?Download WordPress

Forums

TinyMCE Advanced
TinyMCE 4.0 not working with WP 3.9 (21 posts)

  1. jefonte
    Member
    Posted 3 months ago #

    Hello, first of all I want to THANKS YOU Andrew for the "setting export" feature, I asked you for that last year and now it is live :)

    Now the issue I have now is that after I click SAVE CHANGES button in the setting page two things happen:

    1- I'm see a message that I have no idea what it means, it says:

    The "Toolbar toggle" button shows/hides the second, third, and forth button rows. It will only work when it is in the first row and there are buttons in the second row.

    2- Nothing change in the WP editor itself.

    Thanks in advance for any advise :)

    https://wordpress.org/plugins/tinymce-advanced/

  2. Jean-Christophe Brebion
    Member
    Posted 3 months ago #

    Hello,
    Same problem for me.
    Here's a screenshot of my config: http://glui.me/?i=pu45975qbkltg81/2014-04-17_at_12.19.png/

  3. jefonte
    Member
    Posted 3 months ago #

  4. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 3 months ago #

    Hmm, this is definitely an error. There is some JS code that checks if the "Toolbar toggle" button is not in the top row. If it is it adds red border. But that JS cannot run if the button is in the bottom area...

    The only explanation I can think of is cached version of the old JS. Delete browser cache and try again :)

  5. Jean-Christophe Brebion
    Member
    Posted 3 months ago #

    Unfortunately, the problem is still there.

    I've tried a fresch install of the plugin on another site and I have the same issue.

  6. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 3 months ago #

    Seems something is wrong with jQuery UI Sortable. Maybe try dragging that button to the second toolbar, then to the first, then save. If the error doesn't show, try dragging it a few times leaving it in the "spare buttons" area at the bottom and save again.

    Alternatively you can get the latest development version from here: http://wordpress.org/plugins/tinymce-advanced/developers/. It has several fixes, including for this problem.

  7. Jean-Christophe Brebion
    Member
    Posted 3 months ago #

    The bug is fixed with the latest dev version. :)
    Thanks !

  8. jefonte
    Member
    Posted 3 months ago #

    I installed the last version which is 4.0.1 today, but it doesn't work for me yet.
    This is my config: http://screencast.com/t/2bghD7TxCN

    But this is what I have in the editor: http://screencast.com/t/0FjBwEpEIYbZ

    As you may see the table button doesn't appear in the editor.

    I tried the ways suggested by Andrew above but I still have this issue.

    Any idea how to fix this??

    Thanks in advance for any help :)

  9. briteventures
    Member
    Posted 3 months ago #

    Please let us know when you get Ultimate TinyMCE to work with the latest WordPress upgrade. This plugin is too important to all of my sites - I don't want to use WP Edit. I need Lorem Ipsum and Clipart and so many other things my users have come to depend on.

    THANK YOU.

  10. Jean-Christophe Brebion
    Member
    Posted 3 months ago #

    @briteventures This topic is about TinyMCE Advanced, not Ultimate TinyMCE.

  11. @Jean-Christophe Brebion... thank you.

    @britventures... Andrew Ozz and TinyMCE Advanced have nothing to do with Ultimate Tinymce or WP Edit.

    First, may I please suggest you read these topics I've posted:
    http://wordpress.org/support/topic/wp-edit-and-wordpress-39-please-read?replies=3

    http://learn.wpeditpro.com/wordpress-tinymce-editor/

    I think those will help clarify a LOT of confusion.

  12. briteventures
    Member
    Posted 3 months ago #

    Oh. My bad. Sorry about that.

  13. jefonte
    Member
    Posted 3 months ago #

    Any update on the original issue? I still have this problem, even with the last version I downloaded today.

  14. digbymaass
    Member
    Posted 3 months ago #

    Using the toggle toolbar button worked for me. But why did I have to search the web to find this answer? It should be clearly documented on the settings page.

  15. But why did I have to search the web to find this answer?

    It's documented in the second link I posted above.

  16. digbymaass
    Member
    Posted 3 months ago #

    That is NOT what appears in the settings window that I see. It should state what you have written/added clearly at the top of the Editor Settings window. I shouldn't have to search the web to know that there is a button controlling whether I see the second row of buttons.

  17. I understand. I'm sure you are not alone. I agree, that button has been my nemesis since day 1.

    However, WordPress is open source, and there is literally tons of information about it via the web. One of the caveats of open source is that there is no 'help desk'. We all volunteer on the forums to try to help as many as possible... but no 1-800 number :)

    So.. I think part of taking an open source product and working on it.. will, at some point, require some researching online. I spend about 20% of my development time on Google, researching.

    Just my $0.02. I'm not right or wrong... just stating my experience :)

  18. digbymaass
    Member
    Posted 3 months ago #

    You'd have a lot less work to do if a little more thought went into the WP and plugins' interfaces. It is strewn with baffling and poorly explained settings. I expect to do research on say, adapting function.php., tinkering with style.css or troubleshooting conflicts, not on basic interfaces like this one.

  19. I understand. Thank you for your interpretation.

  20. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 3 months ago #

    Thanks @Josh :)

  21. :)
    We appreciate you... oh, great and powerful Ozz!

Reply

You must log in to post.

About this Plugin

About this Topic