WordPress.org

Ready to get started?Download WordPress

Forums

Custom Field Template
Tiny MCE Not Appearing with WP 3.2 (8 posts)

  1. Copernicus
    Member
    Posted 3 years ago #

    Hi. I just upgraded a blog to WordPress 3.2 and text areas/fields within my Custom Page Template are not loading the Tiny MCE Visual Editor as expected.

    Naturally, everything was working fine in WP 3.1.4 and the only change I made was in upgrading to WP 3.2.

    (I have version 1.9.2 of the Custom Field Template plugin installed.)

    Anyone else experiencing this? Anyone have a fix?

    Thanks!

  2. mike235
    Member
    Posted 3 years ago #

    I'm having the same problem also, Tiny MCE not showing on custom fields after upgrade to WP 3.2

    I get the following Javascript error :

    Uncaught ReferenceError: tinyMCE is not defined

    EDIT : Solved. Ok Here's what was happening : I had a custom post type, for which the "editor" was deactivated (I was only using custom fields). And in those custom fields the TinyMCE was not loaded. That happened because I had deactivated the editor, apparently it needs to be present for TinyMCE to appear on custom fields.

  3. Copernicus
    Member
    Posted 3 years ago #

    Thanks, mike235! I had a feeling it might be something like that, but didn't think to check my Custom Post Type configuration.

    I, too, had deactivated the Editor (using the Custom Post Type UI plugin, http://wordpress.org/extend/plugins/custom-post-type-ui/).

    While I'm able to get the Tiny MCE interfaces back on the custom fields by ensuring that the Editor is loaded; it defeats the purpose of the custom post type (I want it custom because I DON'T want the standard editor).

    From what I've found, it seems that plugins now need to call the "wp_preload_dialogs()" separately for instances when the Editor is not being employed within a post type. Details here:
    http://dannyvankooten.com/450/tinymce-wysiwyg-editor-in-wordpress-plugin/

  4. mike235
    Member
    Posted 3 years ago #

    Copernicus, you can also hide the WP editor with some CSS. In the following example I'm hiding the editor on the "projects" custom post type admin pages :

    function add_custom_admin_styles() {
    
    	/* Hide editor for "projects" custom post type*/
    	global $post;
    
    	switch ( $post->post_type ) {
    
    		case "projects" :
    			echo '<style type="text/css">#postdivrich{display:none!important;}</style>';
    			break;
    
    	}
    
    }
    add_action('admin_head', 'add_custom_admin_styles');

    It's not the cleanest fix, but it may be enough if you find nothing else that works.

  5. rpetersnmt
    Member
    Posted 3 years ago #

    I've also found that you can do the same thing directly within the Custom Field Template Plugin. See below where I used the "after" bit. I had the same problem with losing the tinyMCE when I hadn't enabled the editor.

    [Activity Directions]
    type = textarea
    rows = 4
    cols = 40
    tinyMCE = true
    label = Provide general directions to/for this Activity
    after = <style type=text/css>#postdivrich {display:none;}</style>

    Maybe that'll help someone too.

  6. Copernicus
    Member
    Posted 3 years ago #

    mike235 & rpetersnmt: fantastic!
    That worked great. Even if it's not the cleanest fix, it'll do quite nicely.

    Thanks to you both!

  7. gluethje
    Member
    Posted 2 years ago #

    rpetersnmt: You rock! This was driving me nuts.

    Not the most elegant fix, but we do what we have to do. Your fix is definitely effective and it's just what I needed to keep things moving on a project. This is the thing that makes WordPress great: the community.

    Thanks!

  8. mt33
    Member
    Posted 2 years ago #

    Thanks guy for the info, was wondering what happened to the TinyMCE editor. Cheers

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic