WordPress.org

Ready to get started?Download WordPress

Forums

Tiny Forge
[resolved] Tiny forge theme (7 posts)

  1. teegee50
    Member
    Posted 4 months ago #

    How can I get different color on site description to that on site title.

  2. Tomas Mackevicius
    Member
    Theme Author

    Posted 4 months ago #

    In style.css under: /* Theme Options - Site Header Logo */

    .site-header h1 a,
    .site-header h2 a {
    	color: #515151;
    	display: inline-block;
    	text-decoration: none;
    }
    .site-header h1 a:hover,
    .site-header h2 a:hover {
    	color: #21759b;
    }

    You might break it down to:

    .site-header h1 a {
    	color: #515151;
    	display: inline-block;
    	text-decoration: none;
    }
    
    .site-header h2 a {
    	color: #515151;
    	display: inline-block;
    	text-decoration: none;
    }
    .site-header h1 a:hover,
    .site-header h2 a:hover {
    	color: #21759b;
    }
  3. teegee50
    Member
    Posted 4 months ago #

    Hi Tomas,
    Sorry but problem not resolved. I'm using achild theme and put the suggested code in it but site title and site description font still the same color. Child theme code below.

    'Template: tiny-forge
    */
    @import url('../tiny-forge/style.css');

    .site-title{
    background-color: #c3c19b; /*This formats OK*/
    }

    .site-header h1 a {
    color: #515151;
    display: inline-block;
    text-decoration: none;
    }

    .site-header h2 {
    color: #000000;
    }

    .entry-title{
    display:none;
    }'

    I tried live editing in Firebug by removing the code between question marks shown below from the parent theme and this gave the right result but I want to do it via the child.

    .site-header h1 a
    ??,.site-header h2 a??
    {
    color: #515151;
    display: inline-block;
    text-decoration: none;
    }

  4. Tomas Mackevicius
    Member
    Theme Author

    Posted 3 months ago #

    Just try to include those several lines in child theme. If you see them crossed out, you can try use !important to enforce the rule.

    And of course it easier to see problem if you would provide your site address.

  5. teegee50
    Member
    Posted 3 months ago #

    Hello Tomas,
    I must be doing something stupid since Firebug isnt showing any CSS from child theme for h2 and !important doesn't work either.
    Site is http://www.thelisteningplace.co.nz/wordpress.

    Your help is much appreciated.

  6. Tomas Mackevicius
    Member
    Theme Author

    Posted 3 months ago #

    Try this one:

    .site-header h2.site-description {
        color: #000;
    }
  7. teegee50
    Member
    Posted 3 months ago #

    Yep it works. Thought I had tried that one but obviously not.

    Many thanks.

Reply

You must log in to post.

About this Theme

About this Topic