WordPress.org

Ready to get started?Download WordPress

Forums

timthumb not working with subdomain? (3 posts)

  1. jason90123
    Member
    Posted 2 years ago #

    I run a blog on my school's free student server at http://cs.unk.edu/~webb . As you can see, my own personal root folder is at ~webb.

    I installed a sweet WooThemes template (Metamorphosis) on my local LAMP installation and got everything working before going to my live site. However, when I went to the live site and updated everything, no thumbnails are being generated by timthumb! Upon closer inspection, it seems that somewhere along the line, timthumb is being given incorrectly referenced URLs, and I can't figure out what to do.

    Specifically, the error thrown by timthumb is "Could not find the internal image you specified." The query strings look something like this "src=~webb/wp-content/uploads/2011/10/IMG_0260-1024x768.jpg&w=200&h=90&zc=1&q=90"

    As you can see, the http://cs.unk.edu/ at the beginning are missing, so its no wonder it doesn't work.

    Any help would be much appreciated! I have tried several different 'solutions' to loosely similar problems I have found, but nothing has worked for my specific case just yet. My site looks a little goofy with a whole bunch of broken images all over the place!

    URL: http://cs.unk.edu/~webb
    Most evident: http://cs.unk.edu/~webb/portfolio

  2. jason90123
    Member
    Posted 2 years ago #

    If I bought a domain name, pointed it to my blog in its current location, then updated my Site URL in WordPress to the domain name, would that fix the issue? I don't want to buy one unless I need to, though.

  3. jason90123
    Member
    Posted 2 years ago #

    Sorry to spam, but I know how quickly things get buried in these forums. Just trying to get an answer :)

Topic Closed

This topic has been closed to new replies.

About this Topic