WordPress.org

Ready to get started?Download WordPress

Forums

timthumb lockfile error (12 posts)

  1. tedhowardnz
    Member
    Posted 2 years ago #

    Can anyone help with the following error message:

    Warning: fopen(./cache/timthumb_int_231fa74f70d57a1d7f66b6919fad3e9a.timthumb.txt.lock) [function.fopen]: failed to open stream: Permission denied in /home/recfish/recfish.co.nz/wp-content/themes/LondonLive/thumb.php on line 777
    A TimThumb error has occured

    The following error(s) occured:
    Could not open the lockfile for writing an image.

    Query String : src=http://www.recfish.co.nz/wp-content/uploads/2011/03/group-surfcasting.jpg&w=340&h=192&zc=1&q=100
    TimThumb version : 2.8

    In the main screen the image is not showing, just a broken link.
    The file is present, in the right location.

  2. Jonathan Dingman
    Member
    Posted 2 years ago #

    Maybe your /cache/ files aren't writable. I would try contacting your web host to see if there are any permission issues.

  3. tedhowardnz
    Member
    Posted 2 years ago #

    Have sent off a request to webhost - unfortunately it is now the weekend here in New Zealand.

    Have just been informed of another somewhat more pressing issue.

    It seems that only I, as administrator, can see the site. Everyone else just sees weird characters -
    Try for yourself - http://www.recfish.co.nz

  4. Jonathan Dingman
    Member
    Posted 2 years ago #

    Ah, I've run into this issue in the past.

    Do you have any sort of caching plug installed?

  5. WPyogi
    Volunteer Moderator
    Posted 2 years ago #

    Yep gibberish. Hacked? Tim thumb has caused major hacking problems in the past...

  6. tedhowardnz
    Member
    Posted 2 years ago #

    Hi Jonathan
    Yes - there is a caching Plugin - W3 Total Cache - and when I look at it's settings it is enabled, but browser caching and and minify are not enabled.
    There are options to autoinstall both.

    While I have been programing for many years, and am familiar with the concept of caching, I have not encountered this particular tool before, and have no knowledge of what it is actually doing or why it is there.

    Page caching is enabled, and is set to disk basic
    Minify is active, but with thewarnings above, probably isn't doing what it ought.

  7. Jonathan Dingman
    Member
    Posted 2 years ago #

    I would disable that for the time being, until your web host can get back to you.

    It's probably with permissions and the files are getting locked up incorrectly.

  8. tedhowardnz
    Member
    Posted 2 years ago #

    Just tried to autoinstall the browser rules, and got:

    The browser cache rules could not be modified. Please run chmod 777 /home/recfish/recfish.co.nz/.htaccess to resolve this issue.

  9. tedhowardnz
    Member
    Posted 2 years ago #

    Disabling the cache did nothing, still looks like garbage on my wife's machine - still perfectly readable on mine.

    Weird!

  10. Jonathan Dingman
    Member
    Posted 2 years ago #

    try clearing out the .htaccess file back to the original state, it could be using the old caching files still.

  11. tedhowardnz
    Member
    Posted 2 years ago #

    Hi Jonathan

    Which .htaccess file - lots of them, in lots of different folders?
    What out it to be?

    Most seem to have 3 lines:
    Options -Indexes
    Order deny,allow
    Deny from all

    the one in the root folder has:

    #BEGIN Image Upload HTTP Error Fix
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>
    #END Image Upload HTTP Error Fix

  12. selnomeria
    Member
    Posted 1 year ago #

    it maybe not a problem of .htaccess, but you need to enter that thumb.php folder, and set "cache" folder's permission to 755 or 777.

Topic Closed

This topic has been closed to new replies.

About this Topic