WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Timthumb and Post Thumbnail Clash?? (3 posts)

  1. osceweb
    Member
    Posted 4 years ago #

    Hi there!

    Firstly. Thanks a lot in advance to anybody who can help. I'm new to the wordpress scene and I have looked EVERYWHERE but can't seem to find the solution

    I used a free theme (Blue Rooster) and began to customise it. The theme uses timthumb along with pretty photo. However...at the time when the theme was released, 2.9.1 wasnt out yet and the Post Thumbnail feature was not built in.

    My problem is: I can get a thumbnail to show up when I add a Custom Field, however when I try using the 'Post Thumbnail' feature, nothing shows up!!! I read that I would have to enable this feature on old themes, so at the moment my funtions.php file has the following:

    <?php
    if ( function_exists('register_sidebar') )
    add_theme_support( 'post-thumbnails' );

    and my index.php looks like this:

    <?php if(have_posts()):?><?php while(have_posts()):the_post();?><?php the_post_thumbnail(); ?>

    However, I don't think that is the problem, because I can SEE 'Post Thumbnails' when i go to edit the post!

    So in Summary: I want to replace the timthumbs with 'post thumbnail' and it isnt working when I add a thumbnail.

    NB: I was using the 'post thumnail' feature on a different theme and it worked fine. I would post up a link to the website, however don't want the post removed for 'advertising'

    Any help would be much appreciated. Thanks.

  2. osceweb
    Member
    Posted 4 years ago #

    I just tried it, and actually it didnt work even with the default wordpress theme! :S No idea why.

  3. osceweb
    Member
    Posted 4 years ago #

    I managed to figure it out. I was missing:

    <?php the_post_thumbnail(); ?>

    from 'category.php' loop! I knew it would be something silly I had forgotten!

Topic Closed

This topic has been closed to new replies.

About this Topic