WordPress.org

Ready to get started?Download WordPress

Forums

Bulk Delete
[resolved] Times Out (5 posts)

  1. freenycpics99
    Member
    Posted 10 months ago #

    Uploaded the utility and it works well for small batches. On larger batches, it times out. The utility seems to contemplate batches larger than 1,000 being beyond its reach and it offers to do only 'X' number of posts....

    Problem is that can't actually be set. I can't set the focus on posts older or more pertinently to say limit the delete to the first 100, 200, 300 posts....

    It just does NOT let me enter a value in there....greyed out...

    http://wordpress.org/plugins/bulk-delete/

  2. Sudar
    Member
    Plugin Author

    Posted 10 months ago #

    The utility seems to contemplate batches larger than 1,000 being beyond its reach and it offers to do only 'X' number of posts....

    It is not a problem with the Plugin. It is because of the limited RAM in your server. The number of posts the Plugin can delete in a single go is limited by amount of RAM that is available to the PHP process in your server. Check out the FAQ's in the Plugin homepage.

    It just does NOT let me enter a value in there....greyed out...

    To delete posts in batches, you have to enable the checkbox that is present in front of checkbox.

  3. lbpp
    Member
    Posted 10 months ago #

    I have the same problem. I fully understand that the script can timeout if your server does not have enough RAM. I DID enable the checkbox in front of the "Only delete first X posts". When you enable the checkbox, the input is still disabled. Is this a bug?

  4. Sudar
    Member
    Plugin Author

    Posted 10 months ago #

    I DID enable the checkbox in front of the "Only delete first X posts". When you enable the checkbox, the input is still disabled. Is this a bug?

    This is interesting. Which browser are you using and also can you find out if there are any JavaScript errors on the page?

    The text box is enabled through JavaScript and if there are JavaScript errors, then it may not be enabled. If you can post the JavaScript error, then I can tell you why this is happening.

  5. Sudar
    Member
    Plugin Author

    Posted 9 months ago #

    There was a JavaScript bug, which was fixed in v4.0.1 of the plugin.

    Kindly try v4.0.1 or above and let me know if you are still facing this issue.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.