WordPress.org

Ready to get started?Download WordPress

Forums

Article List Manager (arlima)
Time zone (13 posts)

  1. Hans
    Member
    Posted 1 year ago #

    I don't know if I'm doing something wrong, but I have a 5 hour difference between my wholesite and Arlima.

    When I plan future posts WordPress places the posts fine at exact right time. Arlima however, places these posts 5 hours later. Then if I go to the post and save it again Arlima will show the post, but if I edit the Arlima list the post will disappear again as if it is again a future post (with same 5 hour diff.)

    I live in the Netherlands and use Time zone Amsterdam for WordPress.

    Website: http://www.haarlemupdates.nl

    http://wordpress.org/extend/plugins/arlima/

  2. Hans
    Member
    Posted 1 year ago #

    P.S. I'm using the latest versions of WordPress and Arlima.

  3. Hans
    Member
    Posted 1 year ago #

    I think it has something to do with the servertime. I tried the plugin on an other site of mine. It is hosted on a server in my own timezone and there the publish times of the plugin works perfect.

    So now I guess the other server is located somewhere else in the world outside my own timezone with a 5 (or 7) hour time difference.

    This plugin is the only one with this problem. Is it possible to make the plugin independable from servertime and use only the publishtimes from the database?

    Can you please help, because I realy do like your plugin! :)
    All other things with your plugin work great. It's only the publishtime problem.

  4. Hans
    Member
    Posted 1 year ago #

    A bit more specific: futurepost date and time on the right list (when I edit my Arlima list) show the right date and time. But when I keep my mouse on the icon with the four little arrows there is this little popup that shows the correct date but the wrong time. The same goes for the list on the left, on mouse over event there is a little popup showing the right date but the wrong time.

    It looks like there are two different timefields in the Arlima database...

    I have a pcicture of this problem at: http://www.haarlemupdates.nl/wp-content/uploads/2013/06/arlima001.jpg

  5. victor_jonsson
    Member
    Plugin Author

    Posted 1 year ago #

    This probably has something todo with timezone settings in php.ini. If you don't have access to the config files of the server you can try to call date_default_timezone_set('Europe/Amsterdam') in wp-config.php

  6. Hans
    Member
    Posted 1 year ago #

    Thank you for your answer, but I have allready done that and it didn't help... I realy think that the plugin is working with two different timefields. If you look at the picture I mentioned above it may be clearer for you.

  7. Hans
    Member
    Posted 1 year ago #

    The time on the right is perfectly okay but the time in the middle is wrong and I don't know where Arlima gets that time from.

  8. victor_jonsson
    Member
    Plugin Author

    Posted 1 year ago #

    It's hard for me to reproduce this error. The plugin is tested on several different servers with different time settings and this error has not come up. You said your self that you've tried it on another server and that it worked as supposed to. I'm not saying that this can't be a bug in Arlima but I don't know how to reproduce the error you're describing.

    Was this plugin installed with the latest version or is it updated to the latest version? Maybe you should try to completely remove the plugin and then download and install it again.

  9. Hans
    Member
    Posted 1 year ago #

    I installed the latest version as a fresh firsttime installation.

    But what I find very strange is that the right column is showing the right time and the other with a time diffference. Why are there two different times in the Arlima table? When it was only the right one it would work perfectly.

    But I will try to remove and re-install it.

  10. Hans
    Member
    Posted 1 year ago #

    Did the remove and re-install, but the problem stays... 5 hour difference. Same column difference.

  11. victor_jonsson
    Member
    Plugin Author

    Posted 1 year ago #

    It's really strange... When a post is added to the list post_date_gmt will be converted to unix time stamp using strtotime. If you update the publish date for a post all articles connected to that post will get a new publish date, using the same code. This should work.

    Check if you get the right time if you load a file on your server in the browser, having the code <?php echo date('H:i:s', time());

  12. Hans
    Member
    Posted 1 year ago #

    It gets even stranger. I asked the hostingcompany about this and the answer was that this server is in my own country and also the time zone is correct.

    PhP time gives the current time correctly. (I have a plugin that gives all the server vaiables.)

    All my other plugins including backupscheduling is working on the right times. Also all cronjobs work perfectly at the right times.

    Indeed, when I (re)save a post it shows up in the frontpage I am using. But when I change something on the Arlima list and save the list some of the posts dissappear (only the post with the strange timething) and I have to save them all again to show up on my page.

  13. Hans
    Member
    Posted 1 year ago #

    And what bothers me the most: the time on the right (see picture above) shows the right publish time and also it shows that the item is published. Future posts show "unpublished" as they should. Only the mouse over shows the wrong time and in the Arlima list on the left, posts are shown as future posts while they are allready published.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic