WordPress.org

Ready to get started?Download WordPress

Forums

Time to First Byte increased from 0.2 seconds to 2.5 seconds after URL change. (2 posts)

  1. gianluca1989
    Member
    Posted 8 months ago #

    Goodmorning,
    i have this configuration

    nginx + php5 + mysql + memcache +fastCGI

    and i have this plug-in

    W3 Total Cache + Nginx Helper

    .
    After change the url from subdirectory to root

    Using a pre-existing subdirectory install
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    Time to First Byte increased from 0.2 seconds to 2.5 seconds
    Before: miosito.com/wordpress 250ms
    After: miosito.com 2.5 sec.

    It's probably a problem of configuration of nginx or other.

    Do you have any advice?

  2. gianluca1989
    Member
    Posted 8 months ago #

    This is a
    /etc/nginx/sites-available/default

    # You may add here your server {
    #	...
    # }
    # statements for each of your virtual hosts to this file
    ##
    # You should look at the following URL's in order to grasp a solid
    # understanding of Nginx configuration files in order to fully unleash
    # the power of Nginx. http://wiki.nginx.org/Pitfalls
    # http://wiki.nginx.org/QuickStart http://wiki.nginx.org/Configuration
    #
    # Generally, you will want to move this file somewhere, and start with a
    # clean file but keep this around for reference. Or just disable in
    # sites-enabled.
    #
    # Please see /usr/share/doc/nginx-doc/examples/ for more detailed
    # examples.
    ##
    server {
    	#listen 80; ## listen for ipv4; this line is default and implied
    	#listen [::]:80 default_server ipv6only=on; ## listen for ipv6
    	root /var/www;
            index index.html index.htm index.php;
            location ~ /nginx.conf { deny all; }
     	# Make site accessible from http://localhost/
    	server_name raspberry.lascienzadellospazio.com;
            location ~* \.(jpg|png|gif|jpeg|css|js|eot)$ {
            expires max; }
    
    	location / {
    		# First attempt to serve request as file, then as
    		# directory, then fall back to displaying a 404.
                    #try_files $uri $uri/ /index.php?$args;
                    try_files $uri $uri/ /wordpress/$uri /wordpress/$uri/ /wordpress/index.php?$args;
    		# Uncomment to enable naxsi on this location include
    		# /etc/nginx/naxsi.rules
    	}
    	location /doc/ {
    		alias /usr/share/doc/;
    		autoindex on;
    		allow 127.0.0.1;
    		allow ::1;
    		deny all;
    	}
    	# Only for nginx-naxsi used with nginx-naxsi-ui : process denied
    	#requests location /RequestDenied {
    	#	proxy_pass http://127.0.0.1:8080;
    	#}
    	#error_page 404 /404.html;
    	# redirect server error pages to the static page /50x.html
    	#
    	#error_page 500 502 503 504 /50x.html; location = /50x.html {
    	#	root /usr/share/nginx/www;
    	#}
    	# pass the PHP scripts to FastCGI server listening on
    	# 127.0.0.1:9000
    	#
    	location ~ \.php$ {
    	fastcgi_split_path_info ^(.+\.php)(/.+)$;
            #NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini
    	# With php5-cgi alone:
    	#fastcgi_pass 127.0.0.1:9000;
    	# With php5-fpm:
    	fastcgi_pass unix:/var/run/php5-fpm.sock;
            fastcgi_index index.php;
            include fastcgi_params;
    	}
    	# deny access to .htaccess files, if Apache's document root
    	# concurs with nginx's one
    	#
    	#location ~ /\.ht {
    	#	deny all;
    	#}
    }
    # another virtual host using mix of IP-, name-, and port-based
    # configuration
    #
    #server {
    #	listen 8000; listen somename:8080; server_name somename alias
    #	another.alias; root html; index index.html index.htm;
    #
    #	location / {
    #		try_files $uri $uri/ =404;
    #	}
    #}
    # HTTPS server
    #
    #server {
    #	listen 443; server_name localhost;
    #
    #	root html; index index.html index.htm;
    #
    #	ssl on; ssl_certificate cert.pem; ssl_certificate_key cert.key;
    #
    #	ssl_session_timeout 5m;
    #
    #	ssl_protocols SSLv3 TLSv1; ssl_ciphers
    #	ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv3:+EXP;
    #	ssl_prefer_server_ciphers on;
    #
    #	location / {
    #		try_files $uri $uri/ =404;
    #	}
    #}

    This is a
    /etc/nginx/nginx.conf

    user www-data;
    worker_processes 1;
    pid /var/run/nginx.pid;
    
    events {
    	worker_connections 768;
    	# multi_accept on;
    }
    
    http {
            # Basic Settings
            sendfile on;
            tcp_nopush on;
            tcp_nodelay on;
            keepalive_timeout 10 10;
            client_max_body_size 15m;
            client_body_timeout 10;
            client_header_timeout 10;
            client_body_buffer_size  1K;
            client_header_buffer_size 1k;
            large_client_header_buffers 4 8k;
            send_timeout 10;
            reset_timedout_connection on;
            types_hash_max_size 2048;
            server_tokens off;
    
            ##
    	# Basic Settings 2 oldest
    	##
    
    	#sendfile on;
    	#tcp_nopush on;
    	#tcp_nodelay on;
    	#keepalive_timeout 65;
    	#types_hash_max_size 2048;
    	# server_tokens off;
    
    	# server_names_hash_bucket_size 64;
    	# server_name_in_redirect off;
    
    	include /etc/nginx/mime.types;
    	default_type application/octet-stream;
    
    	##
    	# Logging Settings
    	##
    
            access_log /var/log/nginx/access.log;
            error_log /var/log/nginx/error.log;
    
            ###
            # Speed up landing page by caching open file descriptors
            open_file_cache max=2048;
    
    	##
    	# Gzip Settings
    	##
    
    	gzip on;
    	gzip_disable "msie6";
    
    	gzip_vary on;
    	gzip_proxied any;
    	gzip_comp_level 6;
    	gzip_buffers 16 8k;
            gzip_min_length   1100;
    	gzip_http_version 1.1;
    	gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;
    
    	##
    	# nginx-naxsi config
    	##
    	# Uncomment it if you installed nginx-naxsi
    	##
    
    	#include /etc/nginx/naxsi_core.rules;
    
    	##
    	# nginx-passenger config
    	##
    	# Uncomment it if you installed nginx-passenger
    	##
    
    	#passenger_root /usr;
    	#passenger_ruby /usr/bin/ruby;
    
    	##
    	# Virtual Host Configs
    	##
    
    	include /etc/nginx/conf.d/*.conf;
    	include /etc/nginx/sites-enabled/*;
    
    }
    
    #mail {
    #	# See sample authentication script at:
    #	# http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
    #
    #	# auth_http localhost/auth.php;
    #	# pop3_capabilities "TOP" "USER";
    #	# imap_capabilities "IMAP4rev1" "UIDPLUS";
    #
    #	server {
    #		listen     localhost:110;
    #		protocol   pop3;
    #		proxy      on;
    #	}
    #
    #	server {
    #		listen     localhost:143;
    #		protocol   imap;
    #		proxy      on;
    #	}
    #}

Reply

You must log in to post.

About this Topic