WordPress.org

Ready to get started?Download WordPress

Forums

Duplicator
[resolved] Time out maybe (9 posts)

  1. MadHag
    Member
    Posted 7 months ago #

    Hi, I have used Duplicater a lot in this past and what a great product.

    The site I am having a problem with has a large package file of around 14gb I have had the max execution time upped to a couple of hours but am still getting a failure, when I check the error log it throws up all I see is this...

    I noticed the php input time is 240 so only 4 minutes or so, do I need to raise that as well?

    BUILD ZIP PACKAGE:
    ********************************************************************************
    PACKAGE DIR: /home/******/public_html
    PACKAGE FILE: /home/******/public_html/wp-snapshots/******82f3b32021_20140118_********_package.zip
    FILTER EXTENSIONS: ''
    FILTER DIRECTORIES: ''
    ----------------------------------------
    STARTING PACKAGE BUILD
    ADDED=>SQL: /home/******/public_html/wp-snapshots/***************_20140118_********_database.sql
    BUILDING FILE LIST

    Thanks.

    http://wordpress.org/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 7 months ago #

    Hey Madhag,

    14GB is going to be too big, some OS have a limit on zips and 2GB and 4GB. You will need to use the filters to get it smaller...

    Thanks~

  3. MadHag
    Member
    Posted 7 months ago #

    Thanks for that, will have to do this one the old fashioned way.

  4. Cory Lamle
    Member
    Plugin Author

    Posted 7 months ago #

    Hey MadHag,

    You can still use the plugin, just exclude any large files or directories and then manually move them over after install. The next version has some tools to help with larger sites... The very latest version (0.5.0) can be found by following these instructions:

    -> Browse to http://wordpress.org/extend/plugins/duplicator/developers/
    -> Look for the section "Other Versions"
    -> Click on "Development Version" and download the zip plugin file
    -> Uninstall your current version and install this one
    -> Note: This is a development line version so please test in your sandbox first to make sure you have no issues...

    Let me know if this solves your issue...

    Thanks

  5. MadHag
    Member
    Posted 7 months ago #

    Thanks, I managed to get the package down to well under 2gb, will try the dev version.

    There was loads of stored databases on the site and multiple duplicate image directories with 23k images in them ( not my site ) looks more like a dropbox account than a webserver

    At the moment I am getting the system constraint error with ajax...blah blah blah its running for 500 secs or so but not completing.

    Thing is its on a good dedicated server and I have all the resources over the top high so it's a bit baffling.

    I have used Duplicater loads of times on my servers but quite small sites and its worked flawlessly. Just this one proving to be a pain. I used scp in the end to move all the files and then updated the db via ssh, its up but now I just want to make a copy for future use.

    http://s24.postimg.org/jy562d3px/system_contraint.png

    http://s23.postimg.org/ssz5xkakb/system_contraint2.png

    Thanks for your help, will try the dev version.

  6. Buko
    Member
    Posted 7 months ago #

    Hi I'm having an error building a package on this site I'm going to be taking care of and rebuilding. I'm really not getting a specific error message just that there is one. I have been able to move the site to my servers the old fashioned way, by exporting and importing the database and just moving the files to my server.

    On my server I have no problem creating an archive using Duplicator. So I did a bit more digging and found that the server running the original site is using php 4.0.8 and my servers are running php 5.4

    Could this be why Duplicator is not working correctly on the original server? I'm using version 0.5

  7. Cory Lamle
    Member
    Plugin Author

    Posted 7 months ago #

    Very likely... The plugin doesn't support PHP versions earlier than 5.2.17

    Hope that helps!

  8. Buko
    Member
    Posted 7 months ago #

    Nevermind I found in the documentation that PHP 5.2 is the minimum. So that answers my question. thanks for the reply I didn't see it as the page was open and not refreshed. I can't believe that a commercial hosting service is running such old software.

  9. Cory Lamle
    Member
    Plugin Author

    Posted 7 months ago #

    I agree! That is a very old version of PHP...

Reply

You must log in to post.

About this Plugin

About this Topic

Tags