WordPress.org

Ready to get started?Download WordPress

Forums

Time out. (12 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    I got WordPress installed perfectly. The tables are in the db and everything. Now when I go to log in via b2login.php I get:
    Fatal error: Maximum execution time of 30 seconds exceeded in c:\apache\apache\htdocs\wp\b2-include\wp-db.php on line 147
    Lines:
    146. // Perform the query via std mysql_query function..
    147. $this->result = mysql_query($query, $this->dbh);
    I'm running wp.72-gold, Apache 1.3.22 (Win32), PHP 4.3.4, MySQL 4.0.16.
    I recently did a fresh install of my webserver, I didn't have this problem before that and the only difference was that I was running PHP 4.0.2 previously.

  2. Anonymous
    Unregistered
    Posted 10 years ago #

    Scratch that. Zone Alarm was being screwy.

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    Ok. I'm going to shoot this.
    It won't work unless Zone Alarm's off?

  4. OperaManiac
    Member
    Posted 10 years ago #

    Man, I got ZA free version installed here with most of the settings set to high. Still never had any problems...

  5. southerngal
    Member
    Posted 10 years ago #

    I have ZA Pro and never had a problem with WP. Maybe it's something else on your computer or your ISP is timing you out. What OS are you running and what browser are you using?

  6. Anonymous
    Unregistered
    Posted 10 years ago #

    I'm guessing your server is on the same computer as ZA? You'll have to configure ZA to open up port 80 and maybe the SQL Server port as well, which is one of these (probably 1433):
    sql*net 66/tcp Oracle SQL*NET
    sql*net 66/udp Oracle SQL*NET
    sqlserv 118/tcp SQL Services
    sqlserv 118/udp SQL Services
    sql-net 150/tcp SQL-NET
    sql-net 150/udp SQL-NET
    sqlsrv 156/tcp SQL Service
    sqlsrv 156/udp SQL Service
    mini-sql 1114/tcp Mini SQL
    mini-sql 1114/udp Mini SQL
    ms-sql-s 1433/tcp Microsoft-SQL-Server
    ms-sql-s 1433/udp Microsoft-SQL-Server
    ms-sql-m 1434/tcp Microsoft-SQL-Monitor
    ms-sql-m 1434/udp Microsoft-SQL-Monitor
    sybase-sqlany 1498/tcp Sybase SQL Any
    sybase-sqlany 1498/udp Sybase SQL Any
    ssql 3352/tcp Scalable SQL
    ssql 3352/udp Scalable SQL
    I'd suggest though that you only open this up for people connecting through 127.0.0.1 as that is your local network (all within the PC) and won't open your system for compromise.

  7. Anonymous
    Unregistered
    Posted 10 years ago #

    Southerngal: I use win98se and ie6.0, which are the same as the previous time. Although another difference I noticed is that I'm using qwestDSL rather than aol dialup. 0.o

  8. Anonymous
    Unregistered
    Posted 10 years ago #

    On second thought, I don't see how it could be my isp or anything on my system. I can use phpmyadmin just fine, which connects to the mysql db's.

  9. Anonymous
    Unregistered
    Posted 10 years ago #

    If it works when ZA is off then it has to be something on your system. Where is your webserver located, in your home?

  10. Anonymous
    Unregistered
    Posted 10 years ago #

    Yea, it's on localhost.
    Could it be because that all of a sudden udp's on port 137 get blocked now? ( It could've started after I installed qwest.net )

  11. southerngal
    Member
    Posted 10 years ago #

    You were on AOL? When you switched to DSL, did you reformat to take all traces of AOL off of your computer? If not, that could be your problem. AOL wraps it's tentacles around all your registry items. I bet that's at least part if not all of the problem. :)

  12. Anonymous
    Unregistered
    Posted 10 years ago #

    See, it only doesn't work when ZoneAlarm is on. When it's off, the script works fine. I've installed another script which also utilizes mysql and I have no problem using it even with ZoneAlarm on.
    I talked to someone about this and they said that timing out is usually caused by infinite loops.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.