WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Popular Posts
[resolved] {thumbs} not displaying any images (3 posts)

  1. iorgad
    Member
    Posted 9 months ago #

    Hello, I installed early today this plugin and i am struggling to display the images of the popular posts. I tried everything like:
    1. check if server has GD installed and it has
    2. uninstalled and installed again the plugin
    3. cleared data of plugin
    4. cleared cache of plugin
    5. changing the Thumbnail source from Featured image to first image on post
    6. checked the permissions on the plugin folder and uploads folder
    7. i read all the other topics from this plugin
    The results are the same: no image is displayed. Can you please help me with this bug? This is the functions i use to display the popula tags:
    <?php if (function_exists('wpp_get_mostpopular')) wpp_get_mostpopular("stats_category=1&post_type=post,page&cat='2,11,5'&range='monthly'&wpp_start='<div class=\"popular\"><h2>Popular Posts</h2>'&wpp_end='<div class=\"clear\"></div></div>'&limit=3&post_html='<div class=\"articleBox\"><div class=\"image\"><div class=\"icon\"><img src=\"/images/icon-photo.png\"/></div>{thumb}</div><p class=\"category\">{category}</p><h3><a href=\"{url}\">{text_title}</a></h3></div>'"); ?>
    I tried even the simple function just with the {thumb} and still nothing appears. Thank you in advance!

    http://wordpress.org/plugins/wordpress-popular-posts/

  2. iorgad
    Member
    Posted 9 months ago #

    Here is the HTML output:

    <div class="popular">
    <h2>Popular Posts</h2>
    <div class="articleBox">
    <div class="image">
    <div class="icon">
    <img src="/images/icon-photo.png">
    </div>
    </div>
    <p class="category">
    <a href="/category/blog/">Blog</a>
    </p>
    <h3>
    <a href="/first-blog-post/">First blog post</a>
    </h3>
    </div>
    <div class="clear"></div>
    </div>
  3. iorgad
    Member
    Posted 9 months ago #

    I just found the response to my problem. I had to add:
    thumbnail_selection='usergenerated'&thumbnail_width='250'&thumbnail_height='80' to wpp_get_mostpopular function.

Reply

You must log in to post.

About this Plugin

About this Topic