WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Thumbnails problem in NextGen Gallery 1.9.8 (4 posts)

  1. Kirdan
    Member
    Posted 1 year ago #

    I use WordPress 3.4.2 (Polish ver.) and have updated NextGen Gallery to ver. 1.9.8. My theme is heavily modified NoLimit. PHP ver. is 5.2.17
    and MySQL ver. is 5.1.57.

    The problem is I do not know, what exactly has crashed, but my six first galleries created before 31st of May 2011 can't display thumbnails on website and look like this:
    http://www.poprostupodroz.com/?p=1206

    The thumbnails are also invisible in Gallery Settings.

    I tried both:
    1) update thumbnails via Bulk Action called "Create new thumbnails" in Gallery Settings; although the process goes to 100% and there is completely no outcome
    2) update single thumbnail by "Edit thumb"; I check the part of of image, click "Update", the message says "Thumbnail updated" (it even shows on the right side!), and still nothing helps.

    The thumbnails do not show either in the Gallery on the website or in Gallery Settings under Thumbnail colummn. The strange thing is anything added after 20th of June, 2011 seems to be OK.

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. smigliorato
    Member
    Posted 1 year ago #

    I noticed that the images you've linked to include spaces and brackets ( '[' and ']' ) in the file name. Your later files don't. Perhaps you changed your file naming scheme, which is why the errors appears to be related to time.

    Sometimes certain characters in urls and in filenames can cause strange issues.

    Try renaming one of the files, and remove or change the spaces and brackets. See if that fixes the issue.

    Rename the files on your computer or server and then re-upload. Here are some ways you can use basic windows functions to automate the process. There are programs to help with this as well.

    If you want to save some work, don't delete the galleries. If you just delete the images, and then re-upload the fixed ones, you will save yourself having to edit the posts and pages where they are included (as the gallery id would change).

  3. Kirdan
    Member
    Posted 1 year ago #

    Thanks, smigliorato. Your intuition was great and really helpful. There was something wrong with the filenames. Actually not the brackets, but blank spaces themselves. According to changelog there was a full rework of permalink url structure in ver. 1.8.0 of NextGen gallery, which took place on 12th of June, 2011. Probably from that version blank spaces in filenames were no longer supported. So I just have to rename files as you pointed out.
    Thank you very much!

  4. Kirdan
    Member
    Posted 1 year ago #

    EDIT: Well, the backets are not supported as well.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic