WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
[resolved] Thumbnails not showing (6 posts)

  1. bck5WG
    Member
    Posted 1 year ago #

    Hi, I like the idea of this plug-in,if I can get it to work.
    1. The thumbnails have only placeholders with diagonal stripes. The pictures do not appear.
    2. Assuming, I'm able to fix the thumbnail problem, how do I suppress the thumbnails from showing on the homepage? I have only excerpts of posts on the homepage so I would like YARP to show up only at the end of the full post.

    http://wordpress.org/extend/plugins/yet-another-related-posts-plugin/

  2. mitcho (Michael Yoshitaka Erlewine)
    Member
    Plugin Author

    Posted 1 year ago #

    1. The thumbnails have only placeholders with diagonal stripes. The pictures do not appear.

    make sure the posts that are showing up as "related" have "featured images" set. http://en.support.wordpress.com/featured-images/#setting-a-featured-image

    2. Assuming, I'm able to fix the thumbnail problem, how do I suppress the thumbnails from showing on the homepage? I have only excerpts of posts on the homepage so I would like YARP to show up only at the end of the full post.

    Go to the YARPP settings page and, under "automatic display", make sure "also display in archives" is turned off.

  3. 4020
    Member
    Posted 1 year ago #

    I'm sorry but I seem to be having the same problem as bck5WG (above). I've just started using YARPP at http://www.vietnam-travel-guide.net/ and don't see how to make the related posts thumbnail come from the related page.

    As you see I changed the default image to replace the "placeholders with diagonal stripes" but (of course) that appears in every thumbnail. I'd like each thumbnail to appear from its related page.

    -------

    And with regard to bck5WG's other question about preventing YARPP from appearing on the homepage ...

    "also display in archives" is turned off but YARPP still appears.

    Thanks.

  4. 4020
    Member
    Posted 1 year ago #

    So there's no way for YARPP to grab the first image as a thumbnail from the page it is linking to? (it must be a "featured image" from a post).

  5. cemtz
    Member
    Posted 1 year ago #

    I am also interested in a hack to show the first image instead of the featured image. I am importing a site from MovableType with more than 1000 posts and it will take us a huge amount of time to set all the featured images.

    Thanks

  6. WPSpeak
    Member
    Posted 1 year ago #

    @cemtz:

    1. First, make sure your theme supports featured image.

    2. Use the code from http://wpforce.com/automatically-set-the-featured-image-in-wordpress/ . It'll automatically grab the first image from the post and set it as featured image. You can also set a default image as fallback in case the post doesn't have an image at all.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.