WordPress.org

Ready to get started?Download WordPress

Forums

Yet Another Related Posts Plugin (YARPP)
Thumbnails Not Displaying Correctly (6 posts)

  1. Mike Turner
    Member
    Posted 4 months ago #

    Hi,

    I just installed this plugin on my multisite which is using the Parabola theme.

    When using the thumbnail output, I get really horrible results.

    Basically I have 3 columns for each related post. The first column is empty, then the 2nd has an image and the 3rd has a title.

    So if I select to have 4 posts; I actually end up with 6 columns across each row.

    Please can you advise if this has been seen before?

    Thanks

    https://wordpress.org/plugins/yet-another-related-posts-plugin/

  2. jeffparker
    Member
    Plugin Author

    Posted 4 months ago #

    Sometimes, certain themes conflict with the display. Would you tell me what version of Parabola you are using, and send the URL of your site or a screenshot of the display? Thanks.

  3. Mike Turner
    Member
    Posted 4 months ago #

    Hi Jeff,

    You can see an example on one of my less busy sites: http://finedon.townvoice.co.uk/2014/02/27/council-tax-frozen-201415/

    I'm currently using Parabola 1.3.3 (latest version)

    Would be great if you could work out how to fix it!

    Thanks

    Mike

  4. jeffparker
    Member
    Plugin Author

    Posted 4 months ago #

    It seems that some theme's surround their featured images with a hyperlink, which conflicts with what YARPP does. I was able to fix this on a test blog of mine by commenting out (adding "//" before) line 316 of theme-loop.php. (Appearance --> Editor --> theme-loop.php)

    function parabola_thumbnail_link( $html, $post_id, $post_image_id ) {
        // $html = '<a href="' . get_permalink( $post_id ) . '" title="' . esc_attr( get_post_field( 'post_title', $post_id ) ) . '" alt="' . esc_attr( get_post_field( 'post_title', $post_id ) ) . '">' . $html . '</a>';

    See if that fixes the issue for you.

  5. Mike Turner
    Member
    Posted 4 months ago #

    Hi Jeff,

    Thank you for your time on this. Yes, it does seem to resolve the layout issue, however it results in the archive / home page which shows the posts, removing the functionality to click on the image to access the post.

    Do you think there is anyway to workaround this to enable both to work together?

  6. jeffparker
    Member
    Plugin Author

    Posted 4 months ago #

    After taking a look at the Parabola settings, I'd recommend removing the fix I suggested and, instead, go here:

    Appearance --> Parabola Settings --> Featured Image Settings

    and uncheck the "Link the thumbnail to the post" checkbox, then click "Save Changes."

    This should take care of the conflict with YARPP.

    Given that, I'm still able to click on images on the home page and get to the posts. Would you provide a screenshot of your home page (or send a link) and point out the unlinked images?

    Thanks.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.