WordPress.org

Ready to get started?Download WordPress

Forums

Thumbnails in Nextgen-Gallery (6 posts)

  1. Kurotsuki
    Member
    Posted 5 years ago #

    I am using Nextgen Gallery but I have a problem with my thumbnails. Look on my site : my site
    As you can see, my images haven't got any thumbnail and they look uggly. I tried to find what was wrong and I noticed that there wasn't any image on my menu, whereas on this one, for exemple : Exemple of working NGG
    If I try to create thumbnail, I receive the following error :
    "Following images can't be created : (Error : Exceed Memory limit. Require : 28.15 MByte)"

    Please help me ! This problem makes me angry. xD

  2. maierma
    Member
    Posted 5 years ago #

    This seems to be, by far, the most common problem for many users due server settings one can't change easily (if at all). And Alex is working on a workaround in the next release.

    Until then, reduce size and resolution of your images and upload them again and see if this solves your problems.

    I assume, your server has a memory limit of 20MByte or so (which you can easily see when you go to "Gallery" where your sever settings are listed).

  3. Kurotsuki
    Member
    Posted 5 years ago #

    Alright. Thanks a lot. However I already tried this by uploading thumbnails and the problem stayed the same. Nevermind, I'll wait that Alex find a solution. Thanks for your reply and sorry for my bad English (there is no way for a French to speak English well ;) )

  4. maierma
    Member
    Posted 5 years ago #

    No need to upload thumbnails, NGG should create these once you have uploaded your pictures OK.

    Resolution (dpi) and size are the key here with the original pictures (before uploading, of course!).

    This CAN work with a few precautions, don't give up too early!

  5. smartjaw
    Member
    Posted 5 years ago #

    yeah - I wasn't getting a lot of definitive answers on why this wasn't working either. let me try to fill in some gaps.

    I am using ipowerweb for hosting and ran into that memory limit issue you mentioned. I scaled my large pictures down from 2048x1536 to 1024x768 at 72 dpi and re-uploaded 6 of them. Now those thumbnails showed up in the Gallery > Manage Gallery page. I had more confidence. I uploaded all the new resized images. I went to Gallery > Manage Gallery > Edit > and clicked the 'Scan folder for new images' button. It got to about 45% and just hung, showing me "Create new thumbnails. Running...please wait". I tried it again and it got to 47% and hung. So now I'm thinking that we're looking at some other mystery limitation, and I need to more than halve the number of images in each gallery, or this won't work.

    Hope this helps. I've read tons of posts on how it doesn't, and read no real answers. Maybe documentation will be forthcoming, as I liked this plugin's interface the best.

    And just a little note to everyone else... Don't just post again and say, "Oh, nevermind, I figured it out". If you post a question, post the answer or delete the post. Thanks!

  6. smartjaw
    Member
    Posted 5 years ago #

    Update to my last comment: Found that the optimum number of images per gallery based on my host's server settings at ipowerweb are 50. Works fine now.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.