WordPress.org

Ready to get started?Download WordPress

Forums

Thumbnails don't display on PC (16 posts)

  1. darkeningskies
    Member
    Posted 4 years ago #

    I have a post with images on my blog, link. The post was done on my MacBook and loads fine (both in the Post Editor section and when looking at the blog). However on my PCs, using Safari/Firefox/IE/Chrome/Opera - none of them display the pictures in the top post (iPhoto to Jalbum). The Macbook loads them fine on either Flock or Safari.

    I get the same thing when making other posts on the PC - I can't generate Thumbnails, I have to generate images at another size after uploading and then reduce them manually to Thumbnail size (hence why that post was written on a Mac).

    All three computers have the latest Java available.

    I get the same problem even on a vanilla WordPress install with no changes made to image directories, no plugins, default theme, etcetera. In the example link above the Uploads folder hasn't been changed at all.

    Most strange of all, even if I go to the link of the thumbnail image on a PC, nothing displays (e.g. here. But if I do the same on the Macbook, it works fine.

    My Uploads directory and subfolders have 777 permission.

    Edit: I have shared hosting, could it be that WordPress wants the server directory rather than a 'public_html' subdirectory?

  2. fldtrace
    Member
    Posted 4 years ago #

    I use PC, and I can see your photos starting after Step1 title, even with IE6.

    I tried in browsercamp and looks OK there too.

    Delete your cache.

  3. darkeningskies
    Member
    Posted 4 years ago #

    I've deleted caches and this is happening on two separate PCs across multiple browsers. It is not a browser cache issue. It might be something to do with my installations of Vista or my anti-virus or some other software on both computers, but it is not the cache.

    Edit: even tried on the virtual machine I run in VMWare Fusion and it doesn't show.

    So for me, the MacBook running OS X 10.5 shows the pictures on any browser. The MacBook running Windows XP does not show the pictures on any browser. Two different desktop PCs (both with decent specs, 2 and 4 gigs ram etc) running Vista 32 and 64 respectively, can't see the pictures on any browser.

  4. fldtrace
    Member
    Posted 4 years ago #

    Wierd enough. What about other websites. Do the picture show up properly on PC's?

  5. darkeningskies
    Member
    Posted 4 years ago #

    Yes, they do - admittedly I don't read many blogs (that I know are specifically WordPress ones) but I'm pretty sure I'd notice missing pictures.

  6. fldtrace
    Member
    Posted 4 years ago #

    Try with this too:

    http://www.xenocode.com/browsers/

    I checked it but the pictures shows properly.

  7. darkeningskies
    Member
    Posted 4 years ago #

    I tried a couple of those plugins, just to check, and still no joy. If I disable images, it shows the image boxes (so those are loading in fine). If I click an image, I see the full image in the Lightbox. It's just the thumbnails.

  8. whooami
    Member
    Posted 4 years ago #

    i see those thumbnails just fine. Its you.

  9. darkeningskies
    Member
    Posted 4 years ago #

    It may be that some other people can see those thumbnails fine, but I can't see them across multiple different PCs with different browsers (including one at my place of work).

    Besides which I don't know of any issue that would case images not to display properly only on certain PCs that is likely to be widespread.

  10. whooami
    Member
    Posted 4 years ago #

    ...but I can't see them across multiple different PCs with different browsers (including one at my place of work).

    well, I just checked from home and I see them fine here also. Thats in addition to my looking 5 hours ago from somewhere else.

    so .. like I said -- its you, or where you are, or whatever.. but its not wordpress.

  11. fldtrace
    Member
    Posted 4 years ago #

    Yes I would say that you setup the computers you are working on in a certain way.

    Try from another computer, you haven't worked in settings and you will see that will work there.

  12. darkeningskies
    Member
    Posted 4 years ago #

    I've tried it on work PCs - I've definitely not set up anything on those. Maybe it's some crazy localisation issue.

  13. fldtrace
    Member
    Posted 4 years ago #

    What operating system the other have?

  14. darkeningskies
    Member
    Posted 4 years ago #

    I've tried it on Vista 64, Vista 32, XP 32 (at work, I have nothing to do with that PC at all so it is unlikely to be a setting there) and XP 32 (in VMWare Fusion on my MacBook).

    I'm bemused. The site isn't throwing up errors in Firefox.

  15. darkeningskies
    Member
    Posted 4 years ago #

    Problem tracked down - for whatever reason, it was Kaspersky (the AV that happened to be run on all those PCs, including the ones that weren't mine). Kaspersky doesn't like WordPress-generated thumbnails.

  16. 8207h32
    Member
    Posted 4 years ago #

    I have same problem. And it was because setting anti spam - algoritms image recognition in Kaspersky enabled. So if you want the thumbnail back, just disable it.

    in Setting > Protection > Content Filtering
    click Settings button in Anti-Spam
    click tab Algorithms > unchek Image recognition (GSG technology) and click OK

    I used KIS 2009

Topic Closed

This topic has been closed to new replies.

About this Topic