WordPress.org

Ready to get started?Download WordPress

Forums

FPW Category Thumbnails
[resolved] Thumbnail Showing in Post (11 posts)

  1. KconleyK
    Member
    Posted 1 year ago #

    When I load an image into a post the plugin works great for the category page and adds a thumbnail to the excerpt. However when you open the post there is now the thumbnail in the top left and the original image in the top right where I place it. Is there a way to make the thumbnail only appear in the excerpt and not the Post as well? Thanks

    http://wordpress.org/extend/plugins/fpw-category-thumbnails/

  2. Frank P. Walentynowicz
    Member
    Plugin Author

    Posted 1 year ago #

    Check your theme first. If it displays thumbnails by itself ( the_post_thumbnail(); ) comment out these calls and use FPW Post Thumbnails plugin to control thumbnails display. You can enable thumbnails for excerpts and disable them in a content.

  3. KconleyK
    Member
    Posted 1 year ago #

    I don't know where to find that, I found the thumbnails comment in single.php and deleted it but that deleted the thumbnail from the excerpt page too.

  4. Frank P. Walentynowicz
    Member
    Plugin Author

    Posted 1 year ago #

    It is my understanding that displaying thumbnails is controlled by your theme only. In that case you have to look for two calls following the_post_thumbnail(). These are: the_content() and the_excerpt(). You comment out the_post_thumbnail for the_content() and leave it for the_excerpt(). You have to check other themplates as well. Let me know which theme you use. It will be easier for me to help you.

  5. KconleyK
    Member
    Posted 1 year ago #

    I use Pressa by SMThemes, thank you!!

  6. Frank P. Walentynowicz
    Member
    Plugin Author

    Posted 1 year ago #

    In template theloop.php find the following block:

    if(has_post_thumbnail()) {
    ?><?php if (!is_single()) { ?>" title="<?php printf( $SMTheme->_( 'permalink' ), the_title_attribute( 'echo=0' ) ); ?>"><?php the_post_thumbnail(
    array($SMTheme->get( 'layout', 'imgwidth' ), $SMTheme->get( 'layout', 'imgheight' )),
    array("class" => $SMTheme->get( 'layout','imgpos' ) . " featured_image")
    ); ?>
    <?php } else { ?>
    <?php //the_post_thumbnail(
    //array(278, 173),
    //array("class" => $SMTheme->get( 'layout','imgpos' ) . " featured_image")
    //); ?>
    <?php }
    }

    I've already commented out the second occurence of the_post_thumbnail call ( look for // ). Place // where I did it. If you've commented out the first occurence, reverse it as it is for excerpts. That's all.

  7. KconleyK
    Member
    Posted 1 year ago #

    How do I comment it out, do I delete something or add something?

    Thanks

  8. KconleyK
    Member
    Posted 1 year ago #

    That worked, Thanks!!!

  9. KconleyK
    Member
    Posted 1 year ago #

    actually no my excerpts are showing up like below with "title" permalinks after makign the above change. Any ideas?

    " title="Permalink to Whiskey Creek Golf Club"> Whiskey Creek is located about 20min outside of the Frederick, MD area in a town called Ijamsville. The course is not far off I-70 so is easily accessible. It opened in 2000. Read More...Check Out the Full Review Here

  10. KconleyK
    Member
    Posted 1 year ago #

    figured it out, thanks

  11. brando6090
    Member
    Posted 9 months ago #

    I'm having this same issue on post pages for my website http://lds-quotes.com and can't seem to figure out how to disable the double thumbnail. Can you help? Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic