WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Sitewide Tags Pages
[resolved] Thumbnail problem (Detube theme) (5 posts)

  1. palmetia
    Member
    Posted 1 year ago #

    Sitewide Tags + DeTube theme.

    I have a parent site and then sub-blogs for that one on a Multisite installation. Currently they all use the same theme (Detube), probably can't get it to work with separate themes unless there is some kind of solution for this thumbnail problem, then it might not matter what theme the blogs use... I don't know, I'm happy to use DeTube for all sites if that's the easiest.

    So basically DeTube theme on main site will with help of sitewide tags plugin grab new blog posts from sub-blogs to main page - BUT it will only display the thumbnail from the post if I've posted a video (you can post articles without videos in DeTube also, that's when my problems start).

    SO: If I have an article with images inside post + a featured image but NO video link, it only creates a thumbnail/featured image on the sub-blog frontpage (there everything works perfectly and doesn't matter if there's no video, if I set a featured image it will show that one as a thumbnail).

    But it actually won't grab the very same thumbnail it created for the blog page to the main domain, where I try to display all posts from all sub blogs with a post thumbnail (whether it's just an article or a video). But then again if I post a video to the blog and it creates a video thumbnail, then those also show on the main page.

    I know that the images are on a sub-domain but basically because it can grab those video thumbnails and make it work, I don't get it why it can't grab the featured image thumbnails as well?

    How could I get it to include the thumbnails also from "plain articles" (= the featured images), and not just video thumbnails from articles w/ video? Is it doable? Don't mind digging in the code if someone tells me what to look for or change.

    http://wordpress.org/extend/plugins/wordpress-mu-sitewide-tags/

  2. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

  3. palmetia
    Member
    Posted 1 year ago #

    I actually got it to work! Instead of "Featured image" I used the "Video poster" (a function in Detube for video post settings) where you can upload a preview image for video file. So basically I can do that for articles without videos, then it shows a thumbnail (featured image) for the post also on main site :) No extra trouble, just glad it was doable somehow!

  4. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 1 year ago #

    Awesome :)

  5. palmetia
    Member
    Posted 1 year ago #

    One more question - domain mapping, would it work with this plugin? I have a blogname.maindomain.com url for the blog now (WPMU) and would like to connect it with my http://www.blogname.com domain so url:s in future would be http://www.blogname.com/2013/02/..... instead. Would the posts from the blog show up on mainsite if I do that?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic