WordPress.org

Ready to get started?Download WordPress

Forums

JM Twitter Cards
[resolved] Thumbnail Image Resize Error (5 posts)

  1. zgambler
    Member
    Posted 8 months ago #

    Not sure if this changed with the latest update, but my thumbnail images all randomly started resizing to only show the middle section of the image.

    Here are some examples of both sides:

    Working (shows the full, square thumb):
    https://twitter.com/soundisstyle/status/361971717796675584
    https://twitter.com/soundisstyle/status/362069551204151298

    Not Working (cuts off parts of the image from the post):
    https://twitter.com/soundisstyle/status/362829036277334016
    https://twitter.com/soundisstyle/status/362306028525719552

    Not sure why it started doing this?

  2. jmlapam
    Member
    Plugin Author

    Posted 8 months ago #

    Yeah I added a crop parameter to prevent Twitter from doing wrong with images but it can be problematic if you use different sizes as source image.

    Be sure to check by editing your image and see how the thumbnail looks like. If you get this all the time, just remove crop parameter in plugin file on lines 57,58,59,60.

    You can also activate summary large card to get large image on your tweets (needs to be approved by Twitter so you may have to submit again).

  3. jmlapam
    Member
    Plugin Author

    Posted 8 months ago #

    3.3.0 should fix your problem, just select false in option page > Thumbnails > crop

  4. esaky
    Member
    Posted 2 months ago #

    Hi,
    Thanks for awesome plugin. Our blog was approved.
    But for homepage and the recent post only validate. When i checked with other post it's showing error:
    "Failed to find ProxyImageByMinDimensionsResponse for http://cdn2.animhut.com/wp-content/uploads/2014/01/tablets-150x150.jpg
    "
    Link: http://www.animhut.com/articles/review-articles/tips-for-building-a-mobile-friendly-website/

    My post thumbnail is 150*150 and category wise is 240*240. And i set my Media file in the Dashboard as 150*150 by default.

    From your plugin settings i choosed 280*150. I have images inside the article which is min 600px to 1080px width for some articles.

    Please help in this issue. What should i do.

    I did not revoked the custom meta tag option for each article.

  5. jmlapam
    Member
    Plugin Author

    Posted 2 months ago #

    Well you use some CDN for images and I guess Twitter's bot does not have access to it. So try to put robots.txt on subdomains you created :

    User-agent: Twitterbot
        Disallow:

Reply

You must log in to post.

About this Plugin

About this Topic

Tags