WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Thumbnail generated, but html sets size to 0 (6 posts)

  1. themoosemind
    Member
    Posted 1 year ago #

    I currently have the problem, that a thumbnail was generated, but the html sets width and height to zero:

    Attachment page

    Thumbnail

    It didn't happen before and I've only installed a database backup plugin meanwhile. I didn't change the theme.

  2. Andrew
    Forum Moderator
    Posted 1 year ago #

    Not only that, but there is some crazy CSS on it too [screenshot].
    Something really does not want viewers to see the image.

    Is it a problem with just your theme? Have you switched to Twenty Twelve with all plugins deactivated?

  3. themoosemind
    Member
    Posted 1 year ago #

    Can I switch themes for only one page and only for me or do I have to download my blog and test it locally?

    (By the way: Wow, you're fast!)

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    Can I switch themes for only one page

    Not really, switching themes will affect all pages of your WordPress site.

    only for me or do I have to download my blog and test it locally?

    You should work locally, yes, otherwise everyone can see your website switch themes :O

  5. themoosemind
    Member
    Posted 1 year ago #

    I didn't test it with my theme, but it is very unlikely that it is the problem.

    I've just uploaded another image. That worked fine. Then I've uploaded the problematic image with another name - didn't work.

  6. themoosemind
    Member
    Posted 1 year ago #

    Ok, it's definitely the file. I've cropped it a tiny bit, saved it again and it worked: Attachment page, file.

    Maybe it's a bug in WordPress? I'll let the buggy file up, just in case anybody wants to try to reproduce it.

Topic Closed

This topic has been closed to new replies.

About this Topic