WordPress.org

Ready to get started?Download WordPress

Forums

Thumbnail Failure in Nextgen Gallery (26 posts)

  1. srt19170
    Member
    Posted 5 years ago #

    When I attempt to create thumbnails for a gallery, I get the following:

    # ID 32: A failure occurred
    [more]
    [object XMLHttpRequest]

    There does not seem to be any more information available. Clicking on "[more]" just returns to the gallery page.

    wp-content\gallery and all subfolders are 777. This is with a fresh install of v1.0.0 beta 2.

    Any thoughts?

  2. Alex Rabe
    Member
    Posted 5 years ago #

    Which browser do you use ? Please open a bug issue here

  3. caringforapathy
    Member
    Posted 5 years ago #

    I am getting the same error.

    I tried uploading 4 new images to a gallery and it successfully created a thumbnail for the last file I uploaded but it failed on the 3 others. I tried deleting the images and uploading again and failed again.

    I am using WP 2.7 RC2 and NextGen 1.0.0 RC2.

  4. caringforapathy
    Member
    Posted 5 years ago #

    Just noticed that 3 files that failed were landscape ones where as the portrait oriented image successfully had a thumbnail created. All were 800x600 (or 600x800 in the portrait's case).

  5. caringforapathy
    Member
    Posted 5 years ago #

    All fixed!

    I found in the bug report list at the link above that someone recommended that using PHP5 instead for 4 would resolve this issue. My 1&1 server was running 4.4.9 and so I added a .htaccess file and forced it to use PHP5 (5.2.6 is running now) and everything works great. All the thumbnails that failed earlier are now created. This is what I added to my .htaccess file:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    Too easy!

  6. netflow
    Member
    Posted 5 years ago #

    Hmm, already running php 5 and that htaccess trick just crashes the entire blog.. Off to look for another solution

  7. diggingdarren
    Member
    Posted 5 years ago #

    netflow - please post anything you find here. i'm having the same problem.

  8. gfra
    Member
    Posted 5 years ago #

    Same issue here - 1&1 server, no thumbnails, only large images showing. caringforapathy's solution worked for me, too - adding a .htaccess-file forcing php 5 did the trick. Nothing else crashed or looks wrong now...

    Thanx , many greetings from Germany - Gabi

  9. leowys
    Member
    Posted 5 years ago #

    Hi! I have the same problem! I'm using 1and1 server.
    Please can anybody explain step by step the ".htaccess" thing, i have no idea how to do it.

    Thanks.!

  10. Dyno223
    Member
    Posted 5 years ago #

    It's an issue with 1and1 and not having PHP 5 as the default install.

    Adding the two lines to your .htaccess file will fix the problem. With the new lines in my .htaccess file I have no errors, without it the errors come back.

    It is a very confusing problem with 1and1 as it acts as if it is a permissions issue but it's not.

    For step by step...

    The way I do it is to show hidden files in my FTP program (currently using Transmit on Mac). I then right click to edit my .htaccess file using what ever text editor I have available. Simply add the two lines:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    I pasted them in the top of the file.

    Save file and do a refresh of the overview page for the Gallery. It should now show you are using PHP Version 5.2.6 in the info area.

    I have tested this tonight and without running PHP5 this plug-in and several others have issues on 1and1.

    I have submitted a ticket to 1and1 about this, but adding the handler and type to the file works just fine.

  11. leowys
    Member
    Posted 5 years ago #

    Thanks for your instructions! I have no luck with that, i've created the .htaccess y the "Blog" folder of my site and the NextGen Gallery Overview says Version 5.2.6 but thumbnails not working!

  12. ritchiem
    Member
    Posted 5 years ago #

    1 and 1 uses shared storage...sometimes it works and if there is not enough memory you get this

    Fatal error: Out of memory (allocated 33030144) (tried to allocate 3072 bytes) in /homepages/5/d187830993/htdocs/tlb/blog/wp-content/plugins/nextgen-gallery/lib/gd.thumbnail.inc.php on line 183

    I really need to find another host or upgrade...this sucks

  13. cookdrummer
    Member
    Posted 5 years ago #

    thanks so much caringforapathy and Dyno223! that worked like a charm for me!

  14. crabashng
    Member
    Posted 5 years ago #

    Also had the thumbnail problem using nextgen gallery on a 1&1 hosted site. Added the 2 lines as recommended via .htaccess and it worked.....for awhile. Then, it stopped working. Checked .htaccess -- and the change was overwritten - reverted to original settings. For this to work, must WordPress core files be installed in a sub-directory and not root? Not understanding why the .htaccess file got overwritten otherwise.

  15. crabashng
    Member
    Posted 5 years ago #

    when the .htaccess file had the 2 lines added, was unable to access newly created pages - 'received Error 403 - Forbidden' errors. so guess there's 2 problems. ugh.

  16. itsmrchris
    Member
    Posted 5 years ago #

    when I added the two lines to my htaccess file, IE would then ask me to open/save/cancel any attempt to open a php url.

    However in my host's cpanel php config I was able to switch to version 5. I verified this by reloading the nextGen overview page which lists php v 5.2.8

    Still receiving errors when trying to generate thumbnails of 1000 pixel wide landscape photos. Many - but not all. Could this be related to size of the image (filesize - not dimensions) ?

  17. nathanfowler
    Member
    Posted 5 years ago #

    adding the two lines to my .htaccess file worked perfectly, on 1and1.

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    Using Cyberduck on a Mac I did as Dyno223 says and set the view to show hidden files to see .htaccess and paste in the fix.

    thanks!

  18. slugoo
    Member
    Posted 5 years ago #

    When I'm using Cyberduck on a Mac, I don't see the .htaccess file that is supposed to show up after I tell the program to show hidden files. Would updating to PHP5 be as easy as creating a htaccess.txt file in TextWrangler, pasting in the code:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    then uploading it to the proper directory on 1and1's server and then renaming the file to ".htaccess"?

  19. devalshah
    Member
    Posted 4 years ago #

    I am using cyberduck for mac ver 3.2 (4648) and I was able to directly edit file using 'mi' and it solved my problem. Previously, it also seemed to restrict my pix sizes to 800 x 600 or less - that problems is resolved as well.

    Many Thanks to all for the help,

    Pino
    http://www.ArtByPino.com

  20. emcwebdesign
    Member
    Posted 4 years ago #

    admin-ajax.php permissions needed to be changed for me in the wp-admin dir

    works fine!

  21. MindJuice
    Member
    Posted 4 years ago #

    I am on 1and1 and I am having the same problem.

    I have added the php5 lines to beginning of my .htaccess file in the root of my site, but the problem still occurs.

    Any other suggestions?

    Thanks!

  22. MindJuice
    Member
    Posted 4 years ago #

    I uploaded about 40 more images, and about half of them were able to generated thumbnails.

    The other half keep failing with the same error.

    Please help, as I am trying to make a memorial site for my friend who passed away this weekend!

    Thank you!

  23. MindJuice
    Member
    Posted 4 years ago #

    I am using WP 2.8.4 and the current version of NexGEN (downloaded today).

    Other settings are:

    Server Settings
    * Operating System : Linux
    * Server : Apache
    * Memory usage : 13.97 MByte
    * MYSQL Version : 5.0.81-log
    * SQL Mode : Not set
    * PHP Version : 5.2.11
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : Off
    * PHP Memory Limit : 40M
    * PHP Max Upload Size : 20M
    * PHP Max Post Size : 8M
    * PHP Max Script Execute Time : 50000s
    * PHP Exif support : Yes ( V1.4 )
    * PHP IPTC support : Yes
    * PHP XML support : Yes

    Graphic Library
    * GD Version : bundled (2.0.34 compatible)
    * FreeType Support : Yes
    * FreeType Linkage : with freetype
    * T1Lib Support : No
    * GIF Read Support : Yes
    * GIF Create Support : Yes
    * JPG Support : Yes
    * PNG Support : Yes
    * WBMP Support : Yes
    * XPM Support : No
    * XBM Support : Yes
    * JIS-mapped Japanese Font Support : No

  24. conian7
    Member
    Posted 4 years ago #

    I am a 1and1 customer as well. When I set up the database for my wpsite I specified PHP 5. I have another wpsite set up on the same server and NextGEN Gallery works fine on it. However, on this site I am developing right now, the same issue occurs...no thumbnail. If I click to edit thumbnail it shows up with a blank white area.

    These are my Server Settings ACCORDING to NextGen's Overview page

    * Operating System : Linux
    * Server : Apache
    * Memory usage : 13.62 MByte
    * MYSQL Version : 5.0.81-log
    * SQL Mode : Not set
    * PHP Version : 4.4.9
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : On
    * PHP Memory Limit : 40M
    * PHP Max Upload Size : 20M
    * PHP Max Post Size : 8M
    * PHP Max Script Execute Time : 50000s
    * PHP Exif support : Yes ( V1.4 )
    * PHP IPTC support : Yes
    * PHP XML support : Yes

    Notice NextGen reports that my PHP vs is 4.4.9, whereas my admin panel for 1and1 says it is 5. I need some help with this please. I tried the .htaccess trick and the only thing that changed was the vs number...thumbnails still did not appear.

    Thanks

  25. conian7
    Member
    Posted 4 years ago #

    OK.
    What I have discovered after much stress, is that 1and1's server (whether it is the php, the gd-lib or the memory limit...or even a combination of any of them) cannot handle larger images. The images I uploaded were 2592X1944 at 180ppi with a file size range between 1.2mb to 1.6mb.

    When uploading those pics I received this error when it tried to generate thumbnail:

    Fatal error: Out of memory (allocated 32505856) (tried to allocate 10368 bytes) in /homepages/28/********/htdocs/demo1/wp-content/plugins/nextgen-gallery/lib/gd.thumbnail.inc.php on line 183

    What I did after trying .htaccess trix and calling 1and1 support (which was helpful, but not) and a few other tips, was simply reduce the size of the file I uploaded. I reduced the same image to 1024X768 at 72ppi which ended up weighing in at 180kb - uploaded it (had to scan folder for it after uploading - nuisance for another thread) and once detected it generated a thumbnail with absolutely no problem.

    One of the issues I believe is that 1and1 limits the php memory usage no matter what it says you have access to, and therefore has trouble 'digesting' larger images.

    While not an ideal thing, I hope this will help someone workaround the issue. Maybe if enough 1and1 customers complain we can get them to resolve this issue, after all...we are the customers!!!

  26. photon43
    Member
    Posted 4 years ago #

    @caringforapathy

    Thanks so much for your suggestion! It worked with no problems. I was having the exact issue (landscape pictures failed on thumbnail creation - 1&1 server). That host really stinks. I would never recommend them to anyone! Had lots of problems with them over the course of this job.

    Thanks Again!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.