WordPress.org

Ready to get started?Download WordPress

Forums

Three problems with established WordPress install (33 posts)

  1. vogelap
    Member
    Posted 7 years ago #

    I've been running WordPress at http://www.drewvogel.com since June 2005 on my FC5 box but since installing 2.0.4 I've been having trouble in the following areas:

    1. The ability to post comments seems to have disappeared. If a user visits a single-view page, the comments dialog ... just isn't there. Even for me as admin, it's not there.

    2. I've got my Permalinks set to Custom and "/index.php/%year%/%monthnum%/%day%/%postname%/". As long as I do not visit Options->Permalinks, my site functions as expected. However, if I visit Options->Permalinks, my site's permalinks stop functioning unless I set them to the default (I don't even have to click "Update Permalinks Settings"; just visiting the page breaks it), which breaks internal links in my site. This is 100% reproducable.

    I've replaced the classes.php and functions_post.php files with the latest copies in this thread (http://wordpress.org/support/topic/54340/page/2?replies=52) and done all the steps here: codex.wordpress.org/Permalinks#Fixing_Permalink_Problems . I've followed all the steps on http://codex.wordpress.org/Permalinks#Fixing_Permalink_Problems , but my .htaccess is still never updated.

    3. I've got WP-Cache (2.0.17) installed on my machine, but I'm not sure if it's working or not. From Ricardo's documentation and my own previous experience, I expect that WP-Cache adds two lines to the bottom of cached pages: "This first time WP-Cache will add a line with the total time needed to create the page, if the page is directly served from the cache, it adds a second line telling it was served from cache.". However, on my site, only the first line is added ("<!-- Dynamic Page Served (once) in 0.484 seconds -->"), but the second line is never added and the cached pages just pile up in /wp-content/cache.

    These are extremely frustrating issues! Can anyone help with any of them? Thanks in advance!

  2. yosemite
    Member
    Posted 7 years ago #

    Getting 100% packet loss on drewvogel.com...

  3. vogelap
    Member
    Posted 7 years ago #

    Please try again...

  4. yosemite
    Member
    Posted 7 years ago #

    Nope. Tell your sister to get off the phone ;')

  5. vogelap
    Member
    Posted 7 years ago #

    heh. I just checked it a moment ago, and it's up (it wasn't, but now it is). Please try again, and thank you for your patience!

  6. yosemite
    Member
    Posted 7 years ago #

    Nope... Three strikes.

  7. vogelap
    Member
    Posted 7 years ago #

    That's really strange.

    Within the last three minutes:
    * I've clicked it from the link above and it worked.
    * I've opened a browser and cut-and-pasted it from above and it worked.
    * I've gone to BabelFish (http://babelfish.altavista.com/) and translated it and it worked.

    It's working on my end... Could it be something on your end?

  8. vkaryl
    Member
    Posted 7 years ago #

    Could be, 'cause it's loading fine for me.... of course, I have no knowledge of your problem or how to fix, so I'm fair useless...

  9. yosemite
    Member
    Posted 7 years ago #

    Loads fine now...

  10. yosemite
    Member
    Posted 7 years ago #

    1) Says "Sorry, the comment form is closed at this time." Check settings in Options:Discussion and under Membership in Options:General...

    Ack, I'm late ;') 2) index.php should not be in a custom permalink. If it's required, something's broken.

    3) Go to Options:wp-cache and scroll down, click the list pages button. Might help comfort-level.

  11. vogelap
    Member
    Posted 7 years ago #

    Thanks for checking it out. I'm glad you were finally able to get through.

    1. I checked settings in Options->Discussion. I've got the top 6 items checked and made no changes there. Under Options->General, 'Anyone can register' and 'Users must be registered and logged in to comment' were both UNCHECKED (I seem to recall a security scare that instructed us to UNCHECK 'Anyone can register'. Has that storm blown over with 2.04?). I CHECKED them both and saved. Now when I log out and visit an article on my site, the comment form displays.

    2. Ever since I've run WP, I've had to have index.php in my permalink. It's described as "Almost Pretty" on this page: http://codex.wordpress.org/Using_Permalinks. I would dearly love to fix it so I didn't have to have index.php in my permalink (in addition to the larger goal of making it so that when I visit Options->Permalinks my site doesn't bomb). If you've got suggestions on either of those issues, I'd appreciate hearing them!

    3. I believe that the cache pages are being created with each visit to the front page but are not being served from the cache for some reason. Please view the source of my front page and see if you see two WP-Cache lines at the very bottom... I only ever see the line telling me that it's been created ("<!-- Dynamic Page Served (once) in 0.484 seconds -->")

  12. yosemite
    Member
    Posted 7 years ago #

    1) Strange. When you get a chance, test that behavior in another theme?

    2) Re-read http://wordpress.org/support/topic/58389?replies=7 , it looks like you were almost there...

    3) <!-- Dynamic Page Served (once) in 0.513 seconds --> The way wp-cache comments in the source was changed, it no longer does a unique comment if delivering an already-cached page. Check the author's page: http://mnm.uib.es/gallir/wp-cache-2/

  13. vogelap
    Member
    Posted 7 years ago #

    Thanks for your reply. I appreciate your time and effort!

    1. Yes. I'll try it in another theme when I get to the office this morning. The comments form was appearing when I went to bed last night but this morning (with no configuration changes or anything), they're not working again.

    2. I'll go through all the steps in that link again and let you know!

    3. From the author's site, under the heading 'How can I tell if it's working' it says, "This first time WP-Cache will add a lines with the total time needed to create the page, if the page is directly served from the cache, it adds a second line telling it was served from cache." Perhaps I'm misunderstanding it or you're reading a different place on the site, but from that, it sounds like it adds two lines under correct operation.

  14. vogelap
    Member
    Posted 7 years ago #

    I quickly tried switching to another theme (WordPress Default 1.6, Sandbox 0.6.1, and Tarski 1.1.3) and the comments form still did not appear. I've restored it to my original theme.

    (Note that the very first article, "QuickLinks: Articles You’re Here For" does not allow comments. This is by design.)

  15. yosemite
    Member
    Posted 7 years ago #

    From the author's site, under the heading

    Yes, but if you read the comments, you'll see he removed the latter one for performance reasons.

    Going to http://www.drewvogel.com/index.php/2006/08/17/system-strangeness/#respond I see a comment form (attractive, btw ;'), but when I submit my comment, I get "Sorry, you must be logged in to post a comment."

  16. vogelap
    Member
    Posted 7 years ago #

    Thank you for your time and reply! I really appreciate your assistance.

    AH! Thanks for pointing out that the author of the cache removed the second line for performance reasons. I missed that in the comments. I guess it's resolved, and I can strike it from my list of issues. Thank you for helping me to understand!

    Regarding the comments -- I think I discovered something... The comment form displays in Firefox but not in IE. In IE, the comment form doesn't display, no matter if I click the article title from the front page or the link you sent above. From the same computer using Firefox, the comment form displays properly.

    I'll work on the permalink thing a bit more this morning once my office calms down.

  17. yosemite
    Member
    Posted 7 years ago #

    Note:
    http://validator.w3.org/check?uri=http%3A%2F%2Fwww.drewvogel.com%2Findex.php%2F2006%2F08%2F17%2Fsystem-strangeness%2F&charset=%28detect+automatically%29&doctype=Inline&ss=1&verbose=1#line-109

    You need to either make your scripts external or use CDATA, e.g.;
    <script type="text/javascript">
    <![CDATA[
    ... Drew's unescaped script content ...
    ]]>
    </script>

    The other errors are pretty self-explanatory...

  18. yosemite
    Member
    Posted 7 years ago #

    Another note ;'):

    Found <style type="text/css">#commentform{ display: none; }</style> in the source. I think FF is ignoring the diplay:none; but IE is not. My question is what the hell is it doing there in the first place? Afraid I can't answer that one...

  19. vogelap
    Member
    Posted 7 years ago #

    Thanks for your reply. I feel like we're close on solving this issue!
    > You need to either make your scripts external or use CDATA
    >
    I'm not sure how to accomplish those goals. Can you enlighten me? Use small words -- :-) -- I'm no coder!

    > Found <style type="text/css">#commentform{ display: none; }</style> in the source.
    >
    Where can I look to fix that?

  20. moshu
    Member
    Posted 7 years ago #

    I might be wrong (as it often happens) but a few days ago another user had similar "disappearing comments" issues and strange code all over their blog... and they were using the same hashcash thingy.

  21. yosemite
    Member
    Posted 7 years ago #

    Moshu's right (thanks moshu) hashcash may be trying to hide the comment form from those not registered/logged in? Deactivate and test.

    As to the CDATA I gave an example above...

  22. vogelap
    Member
    Posted 7 years ago #

    Thanks Yosemite and Moshu for your replies.

    > Moshu's right (thanks moshu) hashcash may be trying to hide the comment form from those not registered/logged in? Deactivate and test.
    >
    Deactivating hashcash enables comment form to appear again in IE, thereby fixing the problem!

    > As to the CDATA I gave an example above...
    >
    Yes, but where do I make those edits? I don't even know where to look! Or is it better to make the scripts external? Again, not sure how to do that either...

    This afternoon I hope to dig into the permalinks. I anticipate having more questions on that subject!

  23. vkaryl
    Member
    Posted 7 years ago #

    Making scripts external is pretty easy. Take all of the script stuff itself (everything between the <script></script> tags and put it into a file, save it as whatever the name of the script is using the extension .js.

    Then set up the script tagset in the head of each page which needs access to it, like this:
    <script type="text/javascript" src="*.js"></script>, replacing the * with the name of the file you created. And of course, make sure you upload it to the root of your site or wp install, whichever makes most sense.

  24. vogelap
    Member
    Posted 7 years ago #

    > Making scripts external is pretty easy. Take all of the script stuff itself (everything between the <script></script> tags and put it into a file, save it as whatever the name of the script is using the extension .js.
    >
    Thank you for your reply. The question I've got, I guess, is where do I FIND the "script stuff itself"? That's what's confusing me...

    Also, I've disabled HashCash completely. The newer version (3.2 instead of 2.3) made it work in IE but not work in Firefox.

    Now, however, I had to disable my cache again because it would work if you hit the page once (when the cache page is generated), but failed to display (only the white screen) if you hit it again.

  25. yosemite
    Member
    Posted 7 years ago #

    One is in your header.php, but it may be getting generated by your 'live' plugin. Other one is in the footer.php, perhaps the end of the 'live' finctions? Not sure...

    Check the 'live' plugin author's site?

  26. vogelap
    Member
    Posted 7 years ago #

    I have removed that Live plugin. I never used it anyhow... Have the script issues you mentioned previously disappeared from the front page now?

    I had to disable my cache again because it would work if you hit the page once (when the cache page is generated), but failed to display (only a white screen is displayed) if you hit it again. VERY strange.

  27. yosemite
    Member
    Posted 7 years ago #

    Bingo! First one's gone (header). Still have the footer one. The footer one makes reference to "hReview microformat", ring a bell?

    As to the wp-cache blank-page issue there is a fix: Go to Quick look at WordPress issues in May: and scroll down to "On May 17th Pedro Valente (and Dreamhost) shared this regarding wp-cache:"

  28. vogelap
    Member
    Posted 7 years ago #

    Thanks for the reply!

    I think the footer is refering to the Structured Blogging (http://www.structuredblogging.org) plugin I had. I've now deactivated it, so it should be clean. Please let me know what you find.

    Regarding the cache and the fix you mentioned... I had previously applied that fix and in fact it's what is currently in the wp-cache-phase2.php file. Still stumped...

  29. vogelap
    Member
    Posted 7 years ago #

    Here's the results of my latest experiments...

    I carefully followed the instructions (1-5) in wordpress.org/support/topic/58389 (including removing "/index.php" from the permalink in #4) and it didn't work. The URL showed the permalink in the desired format ("http://www.drewvogel.com/2006/08/18/system-strangeness/"), but the page didn't display.

    I noticed that rolling back after the failure -- that is, restoring the backup of my .htaccess file and adding "/index.php" back to the permalink and updating the permalink structure -- did NOT return the site to working order. Simply VISITING Options->Permalinks is enough to cause the site to stop working, no matter if I "Update Permalink Structure" or not. I ended up having to Empty and restore my WordPress database from backup! This is bad.

    Any ideas how to proceed?

    We're back to two issues -- the cache is no longer working (and is currently disabled), and the ongoing permalink issue.

  30. yosemite
    Member
    Posted 7 years ago #

    What's your .htaccess look like?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags