WordPress.org

Ready to get started?Download WordPress

Forums

This webpage has a redirect loop Reload (14 posts)

  1. thakur633
    Member
    Posted 7 months ago #

    I am having trouble to upload my multisite to server from localhost please help.
    My site showing this error "This webpage has a redirect loop Reload"
    and before it shows the error was in wpconfig line 82. than i did the following setting to my config file:

    define( 'WP_ALLOW_MULTISITE', true );
    define('MULTISITE', true);
    define('VHOST', 'yes');
    $base = '/';
    
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'conclusion.co.nf');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);

    please help me. this is first time iam moving my site to server

  2. thakur633
    Member
    Posted 7 months ago #

    Thanks Mike

    But I tried this also it does not work. Do you have any other alternate. Please let me know.

  3. Which ones did you try?

  4. thakur633
    Member
    Posted 7 months ago #

    Edited .htaccess and wpconfig file but it didnt work

  5. gordieschmitt
    Member
    Posted 7 months ago #

    I had similar problems with a new v3.6 install. Finally, I copied my .htaccess code from my earlier v3 multisite setup that I installed a year ago and it seems to work fine. The .htaccess code that the Network Setup told me to use did not work except for the top level site. I noticed that the rewrite code wasn't correcting the paths to various css and js files for new sites, so they weren't loading when the sub-directory sites were in the path.

    The Network setup instructed me to insert this into the .htaccess (which didn't work) file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /engl191-fall2013/
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) var/www/html/wordpress/english/engl191-fall2013/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ var/www/html/wordpress/english/engl191-fall2013/$2 [L]
    RewriteRule . index.php [L]
    </IfModule>
    
    # END WordPress

    I finally replaced the .htaccess file with what I used in an earlier WP version 3 with this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    Options +FollowSymLinks
    RewriteBase /engl191-fall2013/
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    </IfModule>
    
    # END WordPress

    This worked for me after several hours of searching and trying other suggestions. If anyone notices something that I should change, please let me know. I seem to remember having this happen a year ago where the .htaccess code was incorrect and I found what someone else had used. If this is the case, it sure would be nice if the WordPress Network Setup was updated with code that actually works because I spent a lot of time trouble-shooting this.

    I hope this is useful to others.

  6. There are three separate suggestions for wp-config. Did you try all of them?

    If so, try:

    Dump your cache.
    Delete your cookies.

    Double check your .htaccess against http://codex.wordpress.org/htaccess

  7. thakur633
    Member
    Posted 7 months ago #

    I do not know what the problem is but after edited my .htaccess and wp.config file and deleted cookies.
    I got this error
    "This webpage has redirect loop"
    Also i am not able to see my wp-admin login on this site.

  8. What is in your .htaccess? The COMPLETE file please.

    Also what is your whole Multisite section of the wp-config.php look like?

    Finally, can you share with us your URL?

  9. thakur633
    Member
    Posted 7 months ago #

    this is my .htaccess file

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    #upload files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    This is my whole multisite section in wp-config file

    define('WP_DEBUG', false);
    define( 'WP_ALLOW_MULTISITE', true );
    define('MULTISITE', true);
    define('VHOST', 'no');
    $base = '/';
    
    define('SUBDOMAIN_INSTALL', true);
    define('DOMAIN_CURRENT_SITE', 'conclusion.co.nf');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    
    define('ADMIN_COOKIE_PATH', '/');
    
    define('COOKIE_DOMAIN', '');
    
    define('COOKIEPATH', '');
    
    define('SITECOOKIEPATH', '');

    My url is conclusion.co.nf

  10. Is this a brand new Multisite? If so, there's a lot of cruft in your wp-config.php that you didn't need to put in. What directions were you following?

    Also why are you on WP 3.5.1 and not 3.6 if this is new?

    Finally, what directions did you follow to move from localhost to conclusion.co.nf?

    I think that the problem is you have a miss-match between your home and site URLs. But that depends on how you moved from local to live.

  11. rockydude
    Member
    Posted 6 months ago #

    Hello,

    was anyone able to get this fixed?

    I tried every step from this site : http://halfelf.org/2012/multisite-login-loop/

    I still have the same problem.

    Chrome gives me this error "This web page has a redirect loop"

    please help

  12. WPyogi
    Volunteer Moderator
    Posted 6 months ago #

    @rockydude - please do not post your question in other people's threads or more than once. I've deleted your duplicate thread(s) - leaving this one:

    http://wordpress.org/support/topic/multi-site-config-file-issue-new-server-and-new-domain?replies=1

  13. rockydude
    Member
    Posted 6 months ago #

    sorry, i was not aware of the multi-site section.

    thank you

Reply

You must log in to post.

About this Topic

Tags

No tags yet.