WordPress.org

Ready to get started?Download WordPress

Forums

Form Maker
[resolved] "This is not a valid e-mail address" (6 posts)

  1. julesibulesi
    Member
    Posted 4 months ago #

    Hi there.
    Just installed Form Maker for the first time and tried setting up a very simple contact form. The problem I'm running into is that, I have a recipient mail address with an ampersand in it, which is allowed and working, but which Form Maker doesn't accept as valid. Is there anything I can do to fix this?
    Thank you very much,
    Jules

    https://wordpress.org/plugins/form-maker/

  2. webdorado
    Member
    Plugin Author

    Posted 4 months ago #

    Dear julesibulesi,

    Please make sure that you have not set field type to "Email" for other fields. If you are sure that you have done everything right, please give us a link to your form page.

  3. julesibulesi
    Member
    Posted 4 months ago #

    Sorry, I haven't made myself clear enough. This is not happening in the front end, in fact it's not related to any form fields, at all. I just log into the backend, create a new form, go into the form options and enter a mail address into the "Email to send submissions to" field:
    j&s@some-domain.info
    This will prompt the error:
    "This is not a list of valid email addresses."
    If I remove the ampersand, altering the address to
    js@some-domain.info
    everything works fine.
    This might be related to some standardized mail address evaluation routine? The ampersand seems not to be supported on every server and php version, but it is officially allowed in mail addresses and, so far, has worked perfectly fine for me.
    Cheerio,
    Jules

  4. julesibulesi
    Member
    Posted 4 months ago #

    Hm, I'm seeing that even the support forum only accepts the mail address as a link without the ampersand. :-D

  5. webdorado
    Member
    Plugin Author

    Posted 4 months ago #

    Dear julesibulesi,
    We have set a validation for not allowing the & symbol as most of the servers doesn't accept it as well. You should either remove it or if you want we can customize it in a way so as you can put that symbol as well.

  6. julesibulesi
    Member
    Posted 4 months ago #

    Thanks for letting me know, I might remove it, I guess. :-)
    Best regards,
    Julian

Reply

You must log in to post.

About this Plugin

About this Topic