WordPress.org

Ready to get started?Download WordPress

Forums

This file is too big. The maximum upload size for your server is 8M (12 posts)

  1. beetgreen
    Member
    Posted 4 years ago #

    I've been looking through all the forum posts on this topic and I can't seem to be able to resolve this issue. I feel like I've been changing what others have done to solve the file is too big for the php.ini settings. I've inserted:

    post_max_size = 20M
    file_uploads = On
    upload_max_filesize = 20M

    into my php.ini file and due to a few recommendations I've put this file into almost every folder in attempt to make a change (including wp-admin, wp-content etc.). Nothing.

    I've uploaded the file into the ftp trying to bypass the media uploader but it appears that file won't show up doing it that way.

    I'm dying over here!

  2. ccesca
    Member
    Posted 4 years ago #

    Hey Beetgreen... any luck on this one? I'm having the same problem....

  3. bradspaulding
    Member
    Posted 4 years ago #

    create a test.php file with the following line:

    <?php echo phpinfo(); ?>

    and ensure that you are adding those lines to the php.ini file listed under the 'Loaded Configuration File' parameter.

  4. Samuel B
    moderator
    Posted 4 years ago #

    you can try putting this at the top of your .htaccess

    RewriteEngine On
    php_value post_max_size 10M
    php_value upload_max_filesize 10M
    php_value max_execution_time 6000000

    change the values to what you think appropriate

    also, the php.ini is a host file that should already be present on the server
    some hosts allow you to edit - some don't
    ask if in doubt

  5. gcbeehler
    Member
    Posted 4 years ago #

    I've been struggling with this as well. I've contacted my hosting company (GoDaddy) and they said it was a WordPress issue. The whole thing is very frustrating, considering I post music and most of it is well in excess of 8megs (the arbitrary limit I currently have). Nothing I do, allows me to revise this upwards!

  6. Kim09
    Member
    Posted 4 years ago #

    I always upload with ftp and it worked.

  7. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    I have no issue on godaddy

    Log on to your hosting. In your root directory just click on the create new file

    Paste your code above into the new file
    Save it as php.ini

    Done
    Godaddy even has a help document, just search their help area for php.ini

    thats where I learned how to make one

  8. asylumet
    Member
    Posted 4 years ago #

    I kept getting the error "This file is too big. The maximum upload size for your server is 8M." when trying to upload videos.

    My php.ini was set as follows:
    upload_max_filesize = 20M
    post_max_size = 20M

    phpinfo(); returned the following information:
    Directive Local Value Master Value
    upload_max_filesize 20M 20M

    I solved this by adding a php.ini file to the wp-admin with the following in it.

    upload_max_filesize = 20M
    post_max_size = 20M

  9. Sellingsen
    Member
    Posted 4 years ago #

    I'm confused by the same thing (I think)... And still very new to WP.

    I have flv videos I want to upload that are up to 50 mb. How can I embed these on my wordpress site without using embedded youtube or the like??

    Can I link from ftp? If that's an option, how do I do that?

    Any help would be very much appreciated!

  10. N.
    Member
    Posted 4 years ago #

    I'm having issues with this as well. Only my max file size is a measly 2MB for some reason. I need to be able to add video, and of course that's not nearly enough space.

    My php.ini file doesn't even have a place in it for size like that, is it OK if I just copy and paste that code above into it though?

  11. N.
    Member
    Posted 4 years ago #

    Sweet, I just did that, added your code:
    upload_max_filesize = 20M
    post_max_size = 20M
    to my php.ini file and saved it and it worked.

  12. bubbleswp
    Member
    Posted 4 years ago #

    I am having the same problems.

    Trying to change the limit from 2meg to 20 meg.

    I have changed the php.ini file and added it to every directory.

    Added the code suggested by Samuel B to the .htaccess file

    My hostings default for upload limit is 32 meg.

    Any ideas?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.