WordPress.org

Ready to get started?Download WordPress

Forums

AdRotate
[resolved] This ad has no schedules! (10 posts)

  1. GoBieN
    Member
    Posted 11 months ago #

    Since the update my ads stopped working and all of them are displayed in yellow. And start and stop time are 1 january 1970 and displayed in red.

    If I open the ad I see 2 schedules listed but can't do anything with them (need pro) and can't add or activate a schedule.

    http://wordpress.org/plugins/adrotate/

  2. Arnan de Gans
    Member
    Plugin Author

    Posted 11 months ago #

    Sounds like you didn't set up a start and end date for your ad.

  3. GoBieN
    Member
    Posted 11 months ago #

    In the section right above the schedule list, I adjust the dates and click save but still it remains the same.

    In the schedule list I have the 2 schedules which I can't adjust.

    It seems I'm stuck.

  4. Arnan de Gans
    Member
    Plugin Author

    Posted 11 months ago #

    That's odd.

    Does the date you set get saved? Or is it empty again if you edit the ad?
    Also, if you create a new ad, is there a date filled in? Or are the fields empty?

  5. GoBieN
    Member
    Posted 11 months ago #

    After saving the ad and opening it again, the dates are back at 1970.
    The 2 schedules in the list remain.
    Same thing when creating a new ad, because that's what I tried before posting here. I deleted them all and started over.

    Here is a video:
    http://www.youtube.com/watch?v=zSAe44cCEN4

  6. Arnan de Gans
    Member
    Plugin Author

    Posted 11 months ago #

    Strange...

    If you add a new ad, does that start out with the right dates?
    If not, go to AdRotate Settings and click "Clean up database" somewhere 2/3rd down the page. THen try again and see if the dates are correct.

  7. GoBieN
    Member
    Posted 10 months ago #

    New ads show 1970 as start and end date.
    Clean-up empty records in DB did not help, the other 2 buttons (optimize and reevaluate) did nothing either. Editing the ad again and setting yesterday as start and +3 years as end and saved. Ad still has 1970 on it.

    Really don't know what to do next ...

  8. Arnan de Gans
    Member
    Plugin Author

    Posted 10 months ago #

    Seems like something is wrong with your database. Can you check your servers error_log for errors mentioning AdRotate?

  9. GoBieN
    Member
    Posted 10 months ago #

    Found the error.
    It seems that all tables for adrotate are MyISAM tables, but the adrotate_schedule table was innoDB. I had disabled innoDB for performance reasons. Re-enabled innoDB now.

    Thanks for your support.

  10. Arnan de Gans
    Member
    Plugin Author

    Posted 10 months ago #

    Ah, that would be it :)

    InnoDB is faster for a bunch of things, you may want to consider to use it for the tracker and stats table as they generally get quite large.

Reply

You must log in to post.

About this Plugin

About this Topic