WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
[resolved] there's no htaccess file (4 posts)

  1. bailiwick
    Member
    Posted 1 year ago #

    Hi,
    this is very surprising to me, but I have no htaccess file in my root folder. I know there was one from day 1, when I first installed WP. And surely in my last backup folder from 2 months ago (when I didn't use BWPS yet), I can see one, but my site has none at the moment.
    Is it possible that BWPS removed it?
    There's no problem with the site though, everything works fine, but I started to get reports about some IPs being locked out for repeatedly trying to excess nonexistent files. That prompted me to tighten the security a bit. In the process BWPS asked me to paste long list of code into htaccess file. That's when I found I have none.
    Should I create new file and paste new code in it? Is there a chance this might cause some trouble, since site works just fine without any htaccess?

    I'll appreciate any help.

    http://wordpress.org/extend/plugins/better-wp-security/

  2. alicemdesign
    Member
    Posted 1 year ago #

    Check your ftp settings to view "hidden files." It's there.

  3. bailiwick
    Member
    Posted 1 year ago #

    Hi, Thank you for suggestion.
    I have the visibility of those files set on, and I still see none.
    Meanwhile I need to report this: I couldn't wait, so I went ahead and created new htaccess and pasted all BWPS code in it. I should not do that. My whole site crashed. I could open homepage only. None of subpages or articles.
    So I uninstall whole plugin, reinstall it and applied settings with one click options only. This gave me basic security only, but it doesn't cause any problems.
    So my site works now, but I still don't know where my htaccess went.

  4. bailiwick
    Member
    Posted 10 months ago #

    @alicemdesign
    You are correct. My Ftp settings were set to show hidden files, but for some reason I had to refresh the program for it to work.
    So yes, you were correct.
    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic