WordPress.org

Ready to get started?Download WordPress

Forums

Themes not loading on localhost (9 posts)

  1. dchapple
    Member
    Posted 1 year ago #

    I'm running a Mac osx 10.6.8, and using MAMP Pro to handle a localhost set up of a wordpress site.
    I seem to have it configured so when I go to the url:
    " http://dev.mysite:8888/wp-admin/themes.php"

    everything seems to function like a live site, with the exception that only a few themes are visible in "Appearance>>Themes"

    I can not see any difference with the themes that are loading and the ones that are not.
    The folder structures are correct, I did make sure of that.
    Any one have an ideas?

    running v3.4.2 of wordpress, and downloaded current WP themes to double check compatibility issues.

    Only "Twenty Eleven" and "Vikiworks Infinity" show up....

  2. s_ha_dum
    Member
    Posted 1 year ago #

    Check the file permissions of the themes. Make sure all of the permissions match the permissions of the working themes.

  3. dchapple
    Member
    Posted 1 year ago #

    Thanks.
    In MAMP Pro I went to Hosts > General > (Disk location) Permissions, and set owner to "WWW".

    The themes are showing up now. But most of the side tab links are missing (Colors, layout, Background image etc), except for the twenty eleven theme. So there is still something wrong.

    Thanks for any guidance.

  4. dchapple
    Member
    Posted 1 year ago #

    Hmm, maybe this is only a problem in the "preview" of the themes. Seems to work after applying the theme....

  5. s_ha_dum
    Member
    Posted 1 year ago #

    I'd guess it is the same issue. Did you change ownership recursively, so that all child files and directories got changed?

  6. dchapple
    Member
    Posted 1 year ago #

    Not sure what you mean. How do you set folder permissions to 777 on a localhost folder?

  7. s_ha_dum
    Member
    Posted 1 year ago #

    I didn't say set the permissions to 777. I asked if you changed the ownership to 'WWW' ( by going to Hosts > General > (Disk location) Permissions) recursively. Did you change the ownership of all of the subdirectories when you did that? I don't know how MAMP works. I don't use it.

  8. dchapple
    Member
    Posted 1 year ago #

    I'm assuming MAMP pro blankets the whole folder structure with the same settings.
    In this case, when switching owner to _www , you see the permissions set to:
    Directory: r [x] w[x] x[x]
    File: r [x] w[x] x[-]

    And when you select the box next to either "Directory" or File" in order to change those permissions, the "set or "save" button gets grayed out.

    So really all you can do is change the owner from "user" to "-www".

    Now while working on this my background images are getting lost (wheel spinning in the chrome browser)

  9. s_ha_dum
    Member
    Posted 1 year ago #

    It sounds like MAMP may not be able to change the permissions. The OS may not allow it.

    Install HttpFox (FireFox extension), activate it and load your page. You should see requests to your various resources-- images, stylesheets, etc-- and you should see the response codes-- 404, 301, 200, etc. If you are getting a 404 for resources that are where the server is looking it is probably a permission error.

Topic Closed

This topic has been closed to new replies.

About this Topic