WordPress.org

Ready to get started?Download WordPress

Forums

themes don't appear on the network computers (11 posts)

  1. jevrinx
    Member
    Posted 8 years ago #

    I've installed WP on my local PC, it works fine but when tried to access it on other PC on the network, the themes do not appear. It only displays text. Do I need to change the path of.... what? HELP.

  2. marke1
    Member
    Posted 8 years ago #

    The css (stylesheet) file needs to be accessible via HTTP. View the source of your index file and see what it shows for the css item. it should include a URL style link. For example:


    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen,projection" />

    the "bloginfo('stylesheet_url')" is the part that actually grabs your stylesheet url (based on whatever default you have defined) and inserts it in the HTML header for each page.

  3. petit
    Member
    Posted 8 years ago #

    Hey jevenrix!
    You will not get more help by posting your problem in many threads. Keep with the one you started - this one!
    If you get no answer for a couple of days, you may "bump" your thread, by "replying" something, like "No one?"

    Also you must supply more information on how your site is set up.

  4. jevrinx
    Member
    Posted 8 years ago #

    marke1, sori but im really a noob does it mean that i need to change the bloginfo('stylesheet_url');
    like to:
    bloginfo('the path of my css');

    and also, I've open my index.php(themes) and i dont see the code above. Do I have to add this code?

  5. Kafkaesqui

    Posted 8 years ago #

  6. jevrinx
    Member
    Posted 8 years ago #

    ---thread---
    truenorth, you're either using http://127.0.0.1 or http://localhost as the blog and WordPress addresses (Options > General), and this is causing other PCs on the network to look "locally," that is at themselves, for the file(s). Instead, use the IP your PC is assigned on your local network (usually something like 192.168.0.2).
    -------------

    ok where will I see (Options > General)?
    and how exactly will I do this, I really need step by step instructions. plsssss help... newbie here sorry

  7. jevrinx
    Member
    Posted 8 years ago #

    addl'

    where will I set the ip address? what file? what section? plsss

  8. Kafkaesqui

    Posted 8 years ago #

    Options > General (WordPress admin), as noted above. It'll be your WordPress and Blog addresses.

  9. jevrinx
    Member
    Posted 8 years ago #

    "Your Profile and Personal Options"
    then
    website

    is this it???

  10. jevrinx
    Member
    Posted 8 years ago #

    ok I found it! sorry!!!!!
    Now just need to test it.
    thanks. i'll be back once i encounter problems

  11. jevrinx
    Member
    Posted 8 years ago #

    Got it working.
    thanks a lot

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags