WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Themes Applied No Images appear for Multisite sub-directorys sites (7 posts)

  1. pdeal
    Member
    Posted 2 years ago #

    I am now using the 3.2 Multisite with the sub-directory configuration.
    I have been researching the theme issue for the sites I have added.
    dev.domain.com/site1
    dev.domain.com/site2

    I am testing the Mulitsite WordPress to see if we can move out of DNN5.
    I have a single site of WordPress 3.13 running for 1 group to do their website. I have found this one issue I cannot resolve below on the Multsite.

    I have followed the installation for themes in the Site Admin and Network Admin procedures. I have enabled a different theme for each site and in the Site Admin section to see the different tabs; the Settings for the site reflect the theme template and information is correct. I do not see in the Appearance tab any theme to activate besides the 1 theme for the main dev.domain.com main page. The themes tab reflects the theme is Enabled.
    Results:
    I get a page that has only the words not the images of the theme in site1 and site2; each having a different theme enabled.

    I do not know where else to look for correcting the problem.
    Any help on this would be greatly appreciated.

  2. What's in your .htaccess file?

  3. pdeal
    Member
    Posted 2 years ago #

    The default settings from the Multisite install network page.

    I am using the following configuration:

    mysql 5.5
    PHP 5.3.6
    Windows Server 2003
    IIS 6.0
    Ionic's Isapi Rewrite Filter (IIRF) 2.1 (it uses an ini file with the setting below in stead of the htaccess. I do have the htaccess file configured with the below as well though.

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
  4. If you're on IIS6 with the ini file, then that's probably what's up here.

    I don't know if this will help you, but this fellow claims to have solved it.

    http://www.kylecaulfield.com/permalink-for-wordpress-iis-6-mod_rewrite-fixed-free

    It looks like a few people have had problems with IIRF too. And sadly, it's not my forte :( I'm a *nix head.

    http://wordpress.org/support/topic/each-site-seems-to-link-to-the-same-main-site?replies=5

  5. pdeal
    Member
    Posted 2 years ago #

    I have been testing the following: the Helicon Isapi RW (Trial 30day Pay version), Helicon Free version and IIRF, and each one gives me the exact same issue. Each one brings up the site and has the words only, but each one does not apply the theme.

    I did notice the URL is created with the sequence http://dev.sccenespanol.com/site1

    Does show a page not found with the webpage wording, if you use this link to see the results.

    It seems this is the root problem and does not want to load using IIS 6.0 properly.

  6. Yeah, if it was unix I'd say it's not reading your .htaccess correctly. That it's IIS 6 means that it's not reading the config/ini right, but I haven't a clue where it goes or what it is :( I'm tagging this IIS so hopefully someone who's good at that sees this.

  7. pdeal
    Member
    Posted 2 years ago #

    I finally solved the problem. This file configuration now works with IIRF.

    IIRF.ini

    # StatusUrl /iirfStatus
    StatusInquiry ON
    RewriteLog C:\windows\system32\LogFiles\iirf\iirf
    RewriteLogLevel 1
    RewriteRule /eurl\.axd/ - [L]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags